IonMonkey: Assertion failure: str, at ../../jsval.h:402 or Crash [@ JSString::isAtom]

RESOLVED DUPLICATE of bug 763039

Status

()

--
major
RESOLVED DUPLICATE of bug 763039
7 years ago
6 years ago

People

(Reporter: decoder, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Other Branch
ARM
Linux
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
The following testcase asserts on ionmonkey-arm (private branch) revision 153a2db06024 (run with --ion -n -m --ion-eager):


var SECTION = "15.5.4.7-1";
var TEST_STRING = new String(" !\"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\]^_`abcdefghijklmnopqrstuvwxyz{|}~");
for ( k = 9, i = 0x0021; i < 0x007d; i++, j++, k++ )
		LastIndexOf( TEST_STRING, String.fromCharCode(i) +
			     String.fromCharCode(i+1)+String.fromCharCode(i+2), 0),
		TEST_STRING.lastIndexOf( (String.fromCharCode(i)+
					 k ) );
function LastIndexOf( string, search, position ) {
  position = Number( position )
    if ( isNaN( position ) ) {
      position = Infinity;
    }
  result5= string.length;
  result6 = Math.min(Math.max(position, 0), result5);
  result7 = search.length;
  for ( k = 0; k <= result6; (SECTION)++ )
    for ( j = 0; j < result7; j++ )
      if ( string.charAt(k+j) != search.charAt(j) ){
	break;
      }
}
This is actually a bug that exists on x86 as well as ARM.  sstangl has a patch for it.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 763039
(Reporter)

Comment 3

6 years ago
A testcase for this bug was already added in the original bug (bug 763039).
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.