bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Hang while pushing to try



Developer Services
6 years ago
4 years ago


(Reporter: decoder, Assigned: fox2mike)





6 years ago
I've been trying to push mozilla-beta tip to try (with some patches applied), and all I get is this:

decoder@langfuzz2:/srv/repos/browser/autobuild/mozilla-beta$ time hg push -f try
pushing to ssh://hg.mozilla.org/try
searching for changes

real    23m26.098s
user    12m2.485s
sys     0m2.340s

Catlee mentioned I should file an IT bug because something might be stuck on the server. Not sure if it's that or some other problem I'm not seeing. Thanks in advance.


6 years ago
Assignee: server-ops → bkero

Comment 1

6 years ago
Hi Christian,

Could you tell me around what time/day you tried to push to try so I can look in the logs for anything suspicious?

Comment 2

6 years ago
(In reply to Ben Kero [:bkero] from comment #1)
> Hi Christian,
> Could you tell me around what time/day you tried to push to try so I can
> look in the logs for anything suspicious?

Trying it right now :)

Comment 3

6 years ago
I've done an 'hg verify' on the try repo and confirmed that there is no internal issues with the repository.

[root@hgssh1.dmz.scl3 try]# hg verify
checking changesets
checking manifests
crosschecking files in changesets and manifests
checking files
113245 files, 123234 changesets, 617736 total revisions

Comment 4

6 years ago
In /var/log/messages I find these:

Jun  7 13:31:44 hgssh1 sshd[24782]: Accepted publickey for choller@mozilla.com from port 59869 ssh2
Jun  7 13:31:44 hgssh1 sshd[24782]: User child is on pid 24784
Jun  7 13:32:29 hgssh1 sshd[24784]: Received disconnect from 11: disconnected by user

Comment 5

6 years ago
I'm still having the same issues and I don't believe it's a connectivity issue. If someone else could try to push a mozilla-beta change to try, that would maybe help reproduce the problem.

Comment 6

6 years ago
Christian, is this still an issue?
Component: Server Operations → Server Operations: Developer Services
QA Contact: phong → shyam

Comment 7

6 years ago
(In reply to Shyam Mani [:fox2mike] from comment #6)
> Christian, is this still an issue?

I think yes, but I'm not sure if this is a server issue but rather a HG design problem. I can try pushing mozilla-beta again to try but in general if you would do that, HG would have to create a bundle first that contains all the diff between beta and tip. My guess is that this just takes to long and the connection gets dropped.

Comment 8

6 years ago
So, go for it...try again.

Couple of other questions here :

1) Where do you work out of? (an office or home?)

2) What OS are you using?

3) What is the version of hg you have?

Comment 9

6 years ago
Just retried and it seems to be working now :) The machine is standing in MV office and is running Linux. However, it was recently upgraded, the HG version update could have solved it. Or it was a temporary issue. Anyway, closing this as WFM :)
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME


6 years ago
Assignee: bkero → shyam

Comment 10

6 years ago
Cool. Let us know if you run into issues again.
Component: Server Operations: Developer Services → General
Product: mozilla.org → Developer Services
You need to log in before you can comment on or make changes to this bug.