Upgrading from a FF version without prefetch support to a version with prefetch support on Win 7 32-bit - Prefetch was unexpectedly cleared

RESOLVED DUPLICATE of bug 758463

Status

()

defect
RESOLVED DUPLICATE of bug 758463
7 years ago
7 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

15 Branch
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Steps:

1. Install 3/24 Nightly build
2. Upgrade to the latest Nightly build
3. Check the maintenance install log

Expected:

No indication of the prefetch service activating should be evident - the correct expected behavior is that this does not happen on an upgrade from a version without prefetch service support to one with support. The prefetch elimination actually in this case should happen after you launch firefox and wait for 3 minutes.

Actual:

The prefetch elimination service unexpectedly activated and cleared the PF file, set it to read only, and set the registry key correctly. No errors generated as a result, but this does seem odd. Launching firefox and waiting for the pref to be set does end up setting the pref correctly and saying that prefetch elimination already took place (which makes sense in this case, given that it already happened).
Machine specs:

ASUS Eee PC
Intel(R) Atom(TM) CPU N450 @ 1.66 GHz 1.67 GHz
2.00 GB of RAM
32-bit OS
Blocks: 692255
Did you have a service installed that already had prefetch cleared functionality?
I.e. did you have a service already installed before step 1?
(In reply to Brian R. Bondy [:bbondy] from comment #2)
> Did you have a service installed that already had prefetch cleared
> functionality?
> I.e. did you have a service already installed before step 1?

Nope. The maintenance service I had installed was from 3/24. I know this machine in particular hasn't been touched in a while (it's a rarely used machine) and it's close to being a vanilla windows installation (very few modifications to the actual machine, rarely used).

This is actually the first time this ASUS machine has been touched since late March, if that means anything.

I've got another ASUS machine with a 1/10/2012 build as well that I could try reproduce this on if you'd like.
Actually, as coded any upgrade of the service will clear the prefetch.  Only new installs will not clear it.  I can see that this is not fully desirable because a lot of people will be upgrading.

This task will be fixed though by the solution I'm doing in bug 758463.  In that bug I will be no longer be doing clear via updates, but all clears will happen like the 1 time operation clear happens (after 3 minutes).  It will be reset after each update.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 758463
You need to log in before you can comment on or make changes to this bug.