Keyboard shortcuts mixed up in FF 13.0

RESOLVED FIXED

Status

Mozilla Localizations
cy / Welsh
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: reescf, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120601045813

Steps to reproduce:

Downloaded and installed the updated version of firefox (13.0). I am using the 64 bit version for Linux in Welsh. The build is the pre-compiled version available from Mozilla.

Tried to close a tab using ctrl+w (as in all previous versions).

Selected some text and tried to copy it to my clipboard using ctrl+c (as in previous versions).

Tried to save a page using ctrl+d (as in recent versions for this locale, at least).


Actual results:

ctrl+w does nothing as far as I can tell.

ctrl+c now closes the current tab!!! (Though not, apparently, if the text is in a form box on this page?)

ctrl+d does nothing as far as I can tell.

ctrl+s now saves the page.

The shortcuts listed in the menus are not only inconsistent with reality but also inconsistent with any possible reality. For example, according to the menus, ctrl+a does all of the following: quits firefox; selects all; initiates a search. Similarly, ctrl+O is supposed to both open a file and increase the font size; ctrl+n is meant to open a new window and bookmark a page; ctrl+shift+a should both show all bookmarks and show the list of addons; ctrl+i should give information about the page and decrease the font size; and there are probably more.


Expected results:

"should" is an interesting question.

At the very least:

ctrl+c should copy selected text to the clipboard, as before. I realise that "close" also starts with "c" but this is completely non-standard behaviour and something of a recipe for disaster. I don't want to be halfway through filling out my tax return when I inadvertently close the tab and lose everything because I tried to copy some text.

Note that the edit menu still _claims_ that ctrl+c will copy text - no mention of it closing the tab.

I also think:

ctrl+w should close the current tab. It isn't as bad for this not to work as for copying to close the tab, but it is functionality I rely on and the lack of a way to close a tab from the keyboard (except by trying to copy text) is already driving me nuts and I only updated about ten minutes ago.

I actually prefer ctrl+s to save than ctrl+d. It makes no sense in Welsh but it is consistent with the rest of the OS. (And ctrl+d makes no better sense in Welsh that I can think of unless it is from "caDw...".) But whichever you use, please stop switching these around. Decide once and for all if keyboard shortcuts should be standardised or localised for Welsh and stick to that decision.

Personally, I think you should leave the shortcuts as in the standard US version (or the GB version if that's different). I doubt very much that you have enormous numbers of people working on the Welsh localisation and I don't want to see it dropped for lack of quality control. I'd much rather see it available with the standard shortcuts. This works better with addons etc. and the rest of the system anyway. The shortcuts have never, in any case, been properly localised - ctrl+v has always pasted text even though there is no "v" in our alphabet. ctrl+g was supposed to quit firefox for a long time (from "Gadael...") but it never actually worked. (I've no idea why ctrl+a would be chosen - "a" suggests "agor" more than anything but that means "open".)

Obviously, keyboard shortcuts need to be unique and to work as advertised. They should *never* unpredictably close tabs, windows or applications!
Component: Untriaged → cy / Welsh
Product: Firefox → Mozilla Localizations
QA Contact: untriaged → welsh.cy
Version: 13 Branch → unspecified
I imagine this is a dupe of bug 761466, so marking it as such. If you feel that it isn't, feel free to undupe it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 761466
On second thought, this seems like it might be better off as a duplicate of bug 535978.

I don't know the specifics of the timeline with regard to which version of the localization you're using, but some shortcut changes have already been made:

http://hg.mozilla.org/releases/l10n/mozilla-aurora/cy/rev/d5aa63cea37b

It seems you're using Firefox Beta 13, but these changes have been made for Aurora 14. If you want to give them a try, you can download the Welsh localization for Linux here:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-aurora-l10n/firefox-14.0a2.cy.linux-i686.tar.bz2
Duplicate of bug: 535978
(I should really stop making comments when I'm tired....)

I just realized that Firefox Beta 14 is already out. I don't know how the updates are running, but you should eventually be updated automatically, providing you with these changes with little effort.

Please report back once that happens.
(Reporter)

Comment 4

6 years ago
I'm not using Beta. I'm using the stable version 13.0. So I take it some of these issues should be resolved in 14.0 when that comes out?

Note that I filed bug 535978. Marking this one as a duplicate of that strikes me as problematic though I don't know what the criteria for duplicate are. But that bug is marked as affecting PPC OS X. Since that platform is no longer supported by Firefox, I assume that the bug is unlikely to attract much attention.

Moreover, the issue I'm reporting here is a regression in version 13.0 versus versions 12.0 and earlier whereas that one was a general complaint about the setup in the Welsh localisation.

Given that the relevant platform no longer exists, is it possible either to alter that bug appropriately or to close it and reopen this one? I'm not certain what the best way to handle it is so I'm going to reopen this one but I have no objection to this one being closed if it would be better to reconfigure the other one.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

6 years ago
Lets close this bug for the general command key part.  These have been fixed in Aurora 14, which is now in beta.  They should appear in Firefox 14.

If you see these issues again then please report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.