If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Reduce CGI_URI_LIMIT from 8000 to 2083 when using Internet Explorer

RESOLVED FIXED in Bugzilla 4.4

Status

()

Bugzilla
Bugzilla-General
--
minor
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: glob, Assigned: Simon Green)

Tracking

4.0.6
Bugzilla 4.4
Bug Flags:
approval +

Details

Attachments

(1 attachment, 1 obsolete attachment)

729 bytes, patch
glob
: review+
Details | Diff | Splinter Review
(Reporter)

Description

5 years ago
bug 513989 introduced CGI_URI_LIMIT set at 8000 to protect against 414 errors.
8000 was used as it falls just under apache httpd's default max uri length.

unfortunately internet explorer does not support urls that have more than 2083 characters (see http://support.microsoft.com/kb/208427).

we should change CGI_URI_LIMIT to 2083
(Assignee)

Comment 1

5 years ago
Created attachment 632066 [details] [diff] [review]
v1 patch

Included a patch to move this along :)

  -- simon
Attachment #632066 - Flags: review?

Comment 2

5 years ago
Comment on attachment 632066 [details] [diff] [review]
v1 patch

>-use constant CGI_URI_LIMIT => 8000;
>+# See http://support.microsoft.com/kb/208427
>+use constant CGI_URI_LIMIT => 2083;

I see no reason to reduce this limit for all browsers because IE sucks. We should keep 8000 unless IE is explicitly detected. Something like:

  use constant CGI_URI_LIMIT => $ENV{'HTTP_USER_AGENT'} =~ /foo/ ? 2083 : 8000;
Attachment #632066 - Flags: review? → review-
(Assignee)

Comment 3

5 years ago
Created attachment 632074 [details] [diff] [review]
v2 patch

Now with recommended changes.
Assignee: general → sgreen+mozilla
Attachment #632066 - Attachment is obsolete: true
Status: NEW → UNCONFIRMED
Ever confirmed: false
Attachment #632074 - Flags: review?
(Assignee)

Updated

5 years ago
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Updated

5 years ago
Attachment #632074 - Flags: review? → review?(glob)
(Reporter)

Comment 4

5 years ago
Comment on attachment 632074 [details] [diff] [review]
v2 patch

r=glob
Attachment #632074 - Flags: review?(glob) → review+
(Reporter)

Updated

5 years ago
Flags: approval?

Updated

5 years ago
Severity: normal → minor
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: approval? → approval+
Target Milestone: --- → Bugzilla 4.4
(Reporter)

Comment 5

5 years ago
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/Constants.pm
Committed revision 8275.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

5 years ago
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/Constants.pm
Committed revision 8276.

Updated

5 years ago
Summary: reduce CGI_URI_LIMIT from 8000 to 2083 → Reduce CGI_URI_LIMIT from 8000 to 2083 when using Internet Explorer
You need to log in before you can comment on or make changes to this bug.