Last Comment Bug 762799 - Cannot open bookmark from sidebar with keyboard (with Enter key)
: Cannot open bookmark from sidebar with keyboard (with Enter key)
Status: RESOLVED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: 14 Branch
: All All
: -- normal (vote)
: Firefox 16
Assigned To: Mano (::mano, needinfo? for any questions; not reading general bugmail)
:
: Marco Bonardo [::mak]
Mentors:
Depends on:
Blocks: 739451
  Show dependency treegraph
 
Reported: 2012-06-08 00:34 PDT by Rick
Modified: 2012-08-03 06:15 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
+
verified
+
fixed


Attachments
patch (1.12 KB, patch)
2012-06-28 11:12 PDT, Mano (::mano, needinfo? for any questions; not reading general bugmail)
no flags Details | Diff | Splinter Review
patch (1.12 KB, patch)
2012-06-28 11:21 PDT, Mano (::mano, needinfo? for any questions; not reading general bugmail)
mak77: review+
gavin.sharp: approval‑mozilla‑aurora+
gavin.sharp: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Rick 2012-06-08 00:34:15 PDT
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0
Build ID: 20120605113340

Steps to reproduce:

Start (fx14 beta) with a new, blank user profile.
Hit Ctrl+B to open Bookmarks Sidebar.
Select any bookmark using keyboard, eg, the 'Help and Tutorials' bookmark.
Hit Enter to open the bookmark.


Actual results:

Nothing happens.

Checked the Error Console:
Error: TypeError: aView is null
Source File: resource:///modules/PlacesUIUtils.jsm
Line: 655


Expected results:

Bookmark should open page in main window.
Comment 1 Alice0775 White 2012-06-16 06:51:32 PDT
This is regressed by bug 739451
Comment 3 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-06-28 11:12:01 PDT
Created attachment 637597 [details] [diff] [review]
patch
Comment 4 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-06-28 11:21:03 PDT
Created attachment 637606 [details] [diff] [review]
patch
Comment 5 Marco Bonardo [::mak] 2012-06-28 11:22:56 PDT
Comment on attachment 637606 [details] [diff] [review]
patch

Review of attachment 637606 [details] [diff] [review]:
-----------------------------------------------------------------

minimal change, like it.
I also like the fact we just undisclosed a bug that was already there but covered by our previous workaround.
Comment 6 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-06-28 11:26:02 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/6fd744aca078

I'll open a follow-up for tests.
Comment 7 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-06-28 11:28:06 PDT
Comment on attachment 637606 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): frontend-fixes for cpg (bug 739451) which are not backoutable
User impact if declined: Summary says it all.
Testing completed (on m-c, etc.): there are no test for this functionality. I'll open a follow for that.
Risk to taking this patch (and alternatives if risky): No alternatives, but this should be very safe.
String or UUID changes made by this patch: none.
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-06-28 11:50:21 PDT
Comment on attachment 637606 [details] [diff] [review]
patch

Yeah, let's get some testing for this in a followup! Please land ASAP
Comment 9 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-06-28 12:03:19 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/c4dac534629c
Comment 10 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-06-28 12:05:56 PDT
http://hg.mozilla.org/releases/mozilla-beta/rev/48bbc196e9a3
Comment 11 Ed Morley [:emorley] 2012-06-29 00:47:39 PDT
https://hg.mozilla.org/mozilla-central/rev/6fd744aca078
Comment 12 Simona B [:simonab ] 2012-08-03 06:15:54 PDT
Verified on Firefox 15 beta 3 that the bookmarks can be opened from the sidebar using the keyboard (with Enter key). 

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.6:

Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:15.0) Gecko/20100101 Firefox/15.0

Note You need to log in before you can comment on or make changes to this bug.