Last Comment Bug 762805 - plugins.click_to_play;true completely hides Java plugin
: plugins.click_to_play;true completely hides Java plugin
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: 14 Branch
: All All
: -- normal with 1 vote (vote)
: mozilla17
Assigned To: John Schoenick [:johns]
:
:
Mentors:
Depends on: 745030
Blocks: click-to-play
  Show dependency treegraph
 
Reported: 2012-06-08 01:00 PDT by Joergen Ramskov
Modified: 2013-01-18 07:09 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
proposal (1.52 KB, patch)
2012-06-11 17:11 PDT, David Keeler [:keeler] (use needinfo?)
no flags Details | Diff | Splinter Review

Description Joergen Ramskov 2012-06-08 01:00:06 PDT
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0
Build ID: 20120605113340

Steps to reproduce:

Enabled the new "plugins.click_to_play" feature. It works fine for flash on youtube and various other pages I tested, but it doesn't work for the Java applet plugin.

In Denmark, we have something called "NemID", a 2 factor login solution used by most online banks and to logon to government websites (to report taxes, etc.). It requires Java.

Example page: http://www.e-boks.dk/redirect.aspx?logon=personal




Actual results:

The Java Applet is "hidden" - there's no "click to play" option.



Expected results:

Click to play should have given me an option to start the java applet that's used for logon to many websites.
Comment 1 Matthias Versen [:Matti] 2012-06-08 09:44:05 PDT
dupe of bug 747709 or bug 746888 ?
Comment 2 David Keeler [:keeler] (use needinfo?) 2012-06-11 17:11:05 PDT
Created attachment 632073 [details] [diff] [review]
proposal

This is another one of those "because the plugin isn't 'enabled', nsObjectLoadingContent uses OnStartRequest instead of SyncStartPluginInstance and gets everything wrong" bugs (e.g. bug 749455, bug 743429). I think we should add a check in LoadObject to fail early if we're loading a plugin and it's click-to-play.

(For more on specifically this bug, the issue this time is that a URI that doesn't exist is passed to LoadObject. (It looks like this URI comes from the java applet's code attribute.) Without click-to-play, the plugin gets loaded and handles the URI itself. With click-to-play, OnStartRequest sees this as a failed request and cancels the load.)
Comment 3 Blutin 2012-08-09 03:24:53 PDT
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0.1
Java plugin: Java(TM) Platform SE 6 U33 6.0.330.3

Following pages are not working with Firefox 14.0.1 and plugins.click_to_play=true:
http://java.com/en/download/installed.jsp
http://www.java.com/en/download/testjava.jsp

Using respectively the button "Verify Java Version" button / the link "test the currently installed version of Java", the tests fail.

There is no UI to activate the Java plugin like here:
http://javatester.org/version.html

To note also that this last page shows another minor bug: the "click to play" message is cut.

It is possible that this has been fixed in dev releases (aurora, beta or nightly). I don't use them.
Comment 4 David Keeler [:keeler] (use needinfo?) 2012-08-09 11:49:40 PDT
Bug 745030 fixes this. This bug should probably remain open until we're sure it won't get backed out, though.

http://www.java.com/en/download/testjava.jsp works as expected on Nightly.
http://java.com/en/download/installed.jsp doesn't seem to have a visible plugin area, but you can activate it using the icon in the url bar.
The issue with http://javatester.org/version.html is actually a "feature" - if the plugin area is too small to display the ui, we hide the overlay. This makes it look broken, though, so maybe we'll revisit that. Again, you can again use the icon in the url bar to activate the plugin.
Comment 5 John Schoenick [:johns] 2012-08-27 14:32:38 PDT
Bug 745030 isn't likely getting backed out, marking fixed
Comment 6 Paul Silaghi, QA [:pauly] 2012-12-11 02:33:41 PST
CTP overlay is displayed and Java works fine after clicking on it.
Verified fixed on Nightly 20.0a1 (2012-12-10) Win 7 x64.

Note You need to log in before you can comment on or make changes to this bug.