Closed Bug 762866 Opened 7 years ago Closed 7 years ago

No page with most frequently visited site on start-up.

Categories

(Firefox :: Tabbed Browser, defect)

13 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 725579

People

(Reporter: John.Kitz, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120601045813

Steps to reproduce:

Started FF.


Actual results:

Is started.


Expected results:

As of version 13 when I click for a new tab. The new tab opens with the image of the most frequently visited sites, which is a great new feature in my opinion. But this page is not shown on the initial tab shown after FF starts up. It would be great if it did,
Component: Untriaged → Tabbed Browser
QA Contact: untriaged → tabbed.browser
Not sure I understand. Do you want the new tab page to be displayed every time you start Firefox? If this is indeed the issue you are reporting, you can select this in Firefox preferences, by adding "about:newtab" to the list of tabs that are opened at startup.
When I click on the plus sign for a new tab, as off version 13, that new tab opens with a matrix showing the content of the most visited sites in the content area of that new tab. The content of the matrix can be arranged according to user preference by moving the squares around and pinning them down or deleting them. 

The tab with which FF opens at start-up doesn't show that matrix in the content area. It may be a case of "works as designed" or a bug, hence the report.
Oh, yes. After the upgrade, the matrix is not shown (new tab page hidden) but is displayed after selecting the upper right button (show new tab page).

I'll let a dev close this, but seems fine with me. Firefox 12 had a blank page as a new tab, hence this is a solution for making a subtle move to the new tab page design page.
The problem, as of FF 15 is: in Preferences the user can choose all kinds of start pages.
EXCEPT the familiar nine block screen is NOT one of the choices offered!

No, he must start Firefox and then hit CTRL-T to see them.

There is no way (unless he reads about the secret about: thing) to get them right from the start!
I resolved the issue by going to Tools -> Options -> General and then setting the value of "When Firefox starts" to "Show my home page" and the value of "Home Page:" to "about:newtab", but consider this to be a workaround rather than a permanent solution since without making this change to the configuration I consider the start-up behaviour to be inconsistent.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 725579
You need to log in before you can comment on or make changes to this bug.