Smooth scrolling in FF13 generates blur

RESOLVED DUPLICATE of bug 763277

Status

()

--
critical
RESOLVED DUPLICATE of bug 763277
6 years ago
6 years ago

People

(Reporter: banakon, Unassigned)

Tracking

13 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120601045813

Steps to reproduce:

FF13 does enable by default smooth scrolling. smooth scrolling works fine, but...


Actual results:

the smooth scrolling generates blur! 


Expected results:

no blur during the scrolling! as in IE9 (IE9 with acceleration enabled!!, smooth scrolling enabled, on the same machine Vista32 sp2, without clear type).
this behaviour is due to firefox (I'd like to mantain the acceleration enabled!) , I guess, not to my machine/gpu drivers...because this annoying blur does appear even in a PDF text via firefox ( but the same pdf in the external reader looks fine: no blur during scrolling).

I hope that the smooth (vertical) scrolling in Firefox will work in the future without blur. Thanks.
(Reporter)

Updated

6 years ago
Severity: normal → critical
OS: All → Windows Vista
Hardware: All → x86

Updated

6 years ago
Assignee: general → nobody
Group: bugzilla-security
Component: Bugzilla-General → Untriaged
Product: Bugzilla → Firefox
QA Contact: default-qa → untriaged
Version: unspecified → 13 Branch
(Reporter)

Comment 1

6 years ago
why this bug has been assigned to "nobody" ?
Is the blur gone without hardware acceleration in Firefox (tools/options/advanced/general) ?
Please post the graphic section from about:support (enter as URL).
(Reporter)

Comment 3

6 years ago
yes, blur is gone without acceleration, but I become jumpiness (as on a tv set during pannings):
so it is bad: waves during scrolling...and fonts are very hard to read. I "must" to choose absolutely >acceleration in firefox enabled<.

here the info, thanks.

Descrizione scheda graficaNVIDIA GeForce 8800 GT ID produttore0x10deID dispositivo0x0611RAM scheda grafica512Driver scheda graficanvd3dum nvwgf2um,nvwgf2umVersione driver8.17.12.9573Data aggiornamento driver2-9-2012Direct2D attivotrueDirectWrite attivotrue (7.0.6002.18592)Parametri ClearTypeParametri ClearType non trovatiRendering WebGLGoogle Inc. -- ANGLE (NVIDIA GeForce 8800 GT ) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)Finestre con accelerazione GPU1/1 Direct3D 10

        
        AzureBackenddirect2d
(Reporter)

Comment 4

6 years ago
ohhhh doing so as you suggested, I become a poor behaviour now :(

I uncecked the acceleration for testing.

then i checke dit again to get the acceleration as in the past .

now I see blur + jumpiness (before doing so I did not see jumpiness, ....as if unabling /re-enablig the acceleration and restarting firefox, this process has damaged myscrooling now....what to do??

also after doing your suggestion and restoring my settings I notice that the scrolling has changed. before (blur only was better), now I have blur + NOT smooth scrolling :(((
Component: Untriaged → Graphics
Product: Firefox → Core
QA Contact: untriaged → thebes
(Reporter)

Comment 5

6 years ago
sorry I dont understand a thing:

-upgrade to ff13
-smooth scrolling enabled by default
-I like this feature. ok.
-but I notice a little blur
-I wrote here to fil a bug about the blur.
-Versen tell me: try disabling the acceleration.
- disabling the aaceleration I noticed no blur but a lot of bad stuff (font "raster", jumpiness).
- then....I re-enabled the acceleration (I like acceleration)
- restart ff
-reboot
=> now (with the SAME settings regarding scrolling and acceleration) I become:
a little blur PLUS jumpiness!!!!!!??????
i.e. unchecking/checking the box "enable acceleration" produced bad effects.

my post started with "please help me to remove the blur, but the smooth scrolling is fine, very smooth", but now, after this test suggested by Versen, I tell you:

now the blur remains but in ADDITION I see a BAD scrolling, NOT smooth, as before I wrote here.

*really confused*
soory. 
thanks if you help me to obtain the smooth scrooling again, and inthe future remove the blur, but now arised this second problem with the smooth scrolling that become NON-smooth scrolling after this test from Comment#2.
thanks.
(Reporter)

Comment 6

6 years ago
addendum:
here, in this bugzilla, I do NOT notice jumpiness, also the scrolling is GOOD.

but on youtube videos and here
http://www.digital-forum.it/showthread.php?t=61885&page=1334

I notice jumpiness that today and yesterdey I did not notice.

but this forum is fine regarding the smooth scrooling, only a little blur.
banakon: just a note: please can you stop filing bugs in the Bugzilla product? That product is for bugs in the Bugzilla software itself, not for bugs in Firefox.

If you need help with bug filing, try the #qa channel on IRC.

Gerv
(Reporter)

Comment 8

6 years ago
????

I filed 2 bug.
blur + contanier crash after installing 11.3.

may you want to help me?
I dnt have irc.

why it is so hard very hard to talk with mozilla's enginners??

the mozilla forum adressed me here!!!!!!!!!!!!

also...there are some hope that the problem with the blur in firefox (not in ie9) can be resolved or ??

*astonished*
(Reporter)

Comment 9

6 years ago
is it normal that one user (not engineer) must have irc channel to fil a bug, as the forumer are unable to resolve this problem???
how is mozilla organized?
I remain without words...
(Reporter)

Comment 10

6 years ago
Updated from Core to Firefox.  ;)
I guess now I ma ok , i.e. in topic ,)
Component: Graphics → Private Browsing
Product: Core → Firefox
banakon: Please don't change the component and Product.
This is no bug in Firefox. Firefox is basically only the userinterface of the whole browser. Please tell me what your issue have to do with the private browsing feature of the browser ?
Additional note: This is no Forum and you get no help here. bugzilla is a tool for the developers and you can report bugs here if you follow our bug writing guidelines.
A reported bug will be fixed if it can be reproduced.
File the bugs in Firefox:untriaged until someone of our triage team put the bugs in the right component.
Component: Private Browsing → Graphics
Product: Firefox → Core
(Reporter)

Comment 12

6 years ago
are you an honest person?

I switched to firefox (No core) because I have blur in firefox.
browsing feature=> I see blur after upgrading to ff13.

Is this related to firefox or to nvidia, ati, abobe????
I think it is related to firefox, otherwise I 'd had written to other people, right?

I will open a nuw bug direct in firefox, doing so I will not change the componet, and perhaps the engineers will want to read what i write (non only the title).
thanks. 
ehm sorry I write the detail so you can repruduce the bug if you have vista and ff13...
ok, now take a screenshot of this page and I will sent it to poeople that I know.
congratulations.

Comment 13

6 years ago
(In reply to banakon from comment #8)
> may you want to help me?

We try, but it is also up to you to read what has been answered and to understand it.

> also...there are some hope that the problem with the blur in firefox (not in
> ie9) can be resolved or ??

As long as we don't have enough information from you, we do not know yet. 
Crystal balls don't help to track down problems, and reverting the work done here by resetting the Product and Component field does not help either to have the Mozilla community handle your report correctly.

> Is this related to firefox or to nvidia, ati, abobe????
> I think it is related to firefox, otherwise I 'd had written to other people, right?

What you think it is related to does not really matter, as long as you do not KNOW it or cannot PROVE it by showing us the mistake in the code (code of Firefox, code of Core, code of NVidia drivers, code of ATI).

Thanks for your understanding and letting us do our work that is needed in order to hopefully  fix your problem.
(Reporter)

Comment 14

6 years ago
ok, sorry. ;)

thank you foyour reply.
please delete this topic.

here the correct (I hope) 
https://bugzilla.mozilla.org/show_bug.cgi?id=763219

if you have questions I will be happy to answere to reprocude the issue.
thanks and sorry.

Comment 15

6 years ago
"You are not authorized to access bug #763219." so no idea what you wrote there.
Probably you clicked on some "Security" flags or so.

Comment 17

6 years ago
Please STOP filing new bug reports all of the time.
Instead fix your EXISTING reports, like this one here.
It just creates more work for us if you file duplicates and DOES NOT HELP ANYBODY. Thanks.

Updated

6 years ago
Duplicate of this bug: 763224
(Reporter)

Comment 19

6 years ago
sorry. now a change the adress > untriage. hope this will be finally the correct behaviour. sorry.
(Reporter)

Updated

6 years ago
Component: Graphics → Untriaged
Product: Core → Firefox

Comment 20

6 years ago
Banakon: As you repeatedly and willingly ignored comments (like comment 11 and 13 telling you to not play with the Component or Product) we are unable to help you.
I'll propose to disable your Bugzilla account as you continously ignore https://bugzilla.mozilla.org/page.cgi?id=etiquette.html .
Bye.

Updated

6 years ago
Duplicate of this bug: 763219
Do not waste our time with filing multiple bugs reports about the same issue and with different Accounts.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 763277
You need to log in before you can comment on or make changes to this bug.