Restoring text + All data(even cache) fails for a page if Firefox crashes or power goes off

RESOLVED DUPLICATE of bug 898800

Status

()

--
critical
RESOLVED DUPLICATE of bug 898800
7 years ago
5 years ago

People

(Reporter: asmodeusme, Unassigned)

Tracking

({dataloss})

25 Branch
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1
Build ID: 20120607025755

Steps to reproduce:

Few minutes ago the power went out in our building while I was in the middle of typing out a very long post on a forum I frequent. The power came back on and I booted up my PC and opened Firefox


Actual results:


Immediately I got a prompt asking if I wanted to restore my session. I clicked restore and all my tabs loaded



Expected results:


Typing out a very long post on a forum was not restored(should always be restoring all data even when undo close tab across sessions)

but in Chromium I clicked restore and all my tabs loaded including the post message window I had open but to my surprise my entire message was there!
(Reporter)

Updated

7 years ago
Severity: normal → critical
blocking-basecamp: --- → ?
blocking-kilimanjaro: --- → ?
Keywords: regression
Priority: -- → P1
Please do not request blocking on unconfirmed bugs.
This could be bad luck (file corrupted)
blocking-basecamp: ? → ---
blocking-kilimanjaro: ? → ---
Keywords: dataloss
Priority: P1 → --
Sounds like either Firefox was between session saves so your form data wasn't yet saved (modified session restore interval pref?) or you're using something like TabMixPlus (I wasn't sure with the comment about the prompt).
multiple requests for needed information.  closing incomplete. please reopen if you can provided the requested information
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [testday-20120615]
sorry, wrong bug.  too may tabs open...
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 5

6 years ago
Sillius ...

(In reply to Paul O'Shannessy [:zpao] from comment #2)
> Sounds like either Firefox was between session saves so your form data
> wasn't yet saved (modified session restore interval pref?)

what value is in about:config for browser.sessionstore.interval ?


> or you're using
> something like TabMixPlus (I wasn't sure with the comment about the prompt).

are you using this?
Whiteboard: [testday-20120615] → [closeme 2012-07-15]
(Reporter)

Comment 6

6 years ago
(In reply to Paul O'Shannessy [:zpao] (no longer moco, slower to respond) from comment #2)
> Sounds like either Firefox was between session saves so your form data
> wasn't yet saved (modified session restore interval pref?) or you're using
> something like TabMixPlus (I wasn't sure with the comment about the prompt).

when i faced this problem i was using the official build(new profile)
still happens when manually kill firefox

(In reply to Tracy Walker [:tracy] from comment #3)
> multiple requests for needed information.  closing incomplete. please reopen
> if you can provided the requested information

Using a new profile(default prefs)
what more?
Priority: -- → P1
Whiteboard: [closeme 2012-07-15]

Updated

6 years ago
Priority: P1 → --

Comment 7

6 years ago
> still happens when manually kill firefox
using nightly build?

what value is in about:config for browser.sessionstore.interval ?

When you see this after a crash, does it happen for all crashes?
And what are these crash IDs?
Keywords: regression
Summary: Restoring text + All data(even cache) if Firefox crashes or power goes off → Restoring text + All data(even cache) fails for a page if Firefox crashes or power goes off
Whiteboard: [closeme 2012-10-15]
Version: 16 Branch → 15 Branch
(Reporter)

Comment 8

6 years ago
> using nightly build?

18.0a 

> what value is in about:config for browser.sessionstore.interval ?

default value

> When you see this after a crash, does it happen for all crashes?

Yes mostly

No addons installed
But still happens
(Reporter)

Updated

6 years ago
Whiteboard: [closeme 2012-10-15]
Version: 15 Branch → 18 Branch
(Reporter)

Updated

6 years ago
Priority: -- → P1
Version: 18 Branch → Trunk
Please don't set the priority field. Thanks.
Priority: P1 → --
(Reporter)

Updated

6 years ago
Version: Trunk → 21 Branch
(Reporter)

Updated

5 years ago
Version: 21 Branch → 25 Branch
Hi ElevenReds, I came across this bug while marking a similar one as a duplicate. I'm duping this to bug 898800 though there is another related one, bug 883609, where more work may be happening to address the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 898800
Looking at the date, this probably happened before we made writes atomic.
I suspect that the part of the bug related to Firefox crashing/being killed is fixed.
You need to log in before you can comment on or make changes to this bug.