If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

OOP <iframe mozbrowser> tests crash on Windows

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Justin Lebar (not reading bugmail), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
See bug 762049 comment 16.
See also bug 776832 comment 44.
Bug 776832 comment 38 gives these two stack traces:

Thread 40 (crashed)
 0  crashinjectdll.dll!CrashingThread(void *) [crashinjectdll.cpp:cfbb2b8a8728 : 17 + 0x0]
    eip = 0x03511000   esp = 0x08ffffb8   ebp = 0x08ffffec   ebx = 0x00000000
    esi = 0x8f8e8d8c   edi = 0x8b8a8988   eax = 0x00000000   ecx = 0x08ffffb0
    edx = 0x7c90eb94   efl = 0x00010246
    Found by: given as instruction pointer in context
 1  kernel32.dll + 0xb50a
    eip = 0x7c80b50b   esp = 0x08ffffbc   ebp = 0x08ffffec
    Found by: stack scanning

Thread 3 (crashed)
 0  ntdll.dll + 0x7f392
    eip = 0x7791f392   esp = 0x029afbd0   ebp = 0x029afbd0   ebx = 0xfffffffb
    esi = 0x08fe463c   edi = 0x08fe4640   eax = 0xc0000024   ecx = 0x029afbbc
    edx = 0x778e64f4   efl = 0x00000286
    Found by: given as instruction pointer in context
 1  ntdll.dll + 0x2fd0f
    eip = 0x778cfd10   esp = 0x029afbd8   ebp = 0x029afbe8
    Found by: previous frame's frame pointer
 2  nspr4.dll!_PR_MD_UNLOCK [w95cv.c:cfbb2b8a8728 : 312 + 0x6]
    eip = 0x7354a3a0   esp = 0x029afbf0   ebp = 0x029afc0c
    Found by: previous frame's frame pointer
 3  nspr4.dll!PR_Unlock [prulock.c:cfbb2b8a8728 : 315 + 0x8]
    eip = 0x73546472   esp = 0x029afbf8   ebp = 0x029afc0c
    Found by: stack scanning
 4  xul.dll!mozilla::ipc::AsyncChannel::ProcessLink::OnMessageReceived(IPC::Message const &) [AsyncChannel.cpp:cfbb2b8a8728 : 667 + 0x7]
    eip = 0x6cc97caf   esp = 0x029afc00   ebp = 0x029afc0c
    Found by: stack scanning
 5  xul.dll!IPC::Channel::ChannelImpl::ProcessIncomingMessages(base::MessagePumpForIO::IOContext *,unsigned long) [ipc_channel_win.cc:cfbb2b8a8728 : 333 + 0xb]
    eip = 0x6cd7795c   esp = 0x029afc14   ebp = 0x029afc4c
    Found by: call frame info
 6  xul.dll!IPC::Channel::ChannelImpl::OnIOCompleted(base::MessagePumpForIO::IOContext *,unsigned long,unsigned long) [ipc_channel_win.cc:cfbb2b8a8728 : 427 + 0x13]
    eip = 0x6cd77b9d   esp = 0x029afc54   ebp = 0x029afc68
    Found by: call frame info
 7  xul.dll!base::MessagePumpForIO::WaitForIOCompletion(unsigned long,base::MessagePumpForIO::IOHandler *) [message_pump_win.cc:cfbb2b8a8728 : 521 + 0xb]
    eip = 0x6cd7526b   esp = 0x029afc70   ebp = 0x029afc90
    Found by: call frame info
 8  xul.dll!base::MessagePumpForIO::WaitForWork() [message_pump_win.cc:cfbb2b8a8728 : 500 + 0x9]
    eip = 0x6cd7532c   esp = 0x029afc98   ebp = 0x029afcb4
I cannot reproduce this failure on my Windows 7 machine, by the way. At least not with a regular --disable-debug --enable-optimize build, running mochitests from the content/base/test directory.
(Reporter)

Comment 4

5 years ago
I appreciate that you guys are looking at this, but why do we care?  The failures on Windows don't seem to suggest failures on the device...
Probably for similar reasons as those for enabling OOP tests on other platforms.
(In reply to Justin Lebar [:jlebar] (PTO 9/27 - 10/1) from comment #4)
> I appreciate that you guys are looking at this, but why do we care?  The
> failures on Windows don't seem to suggest failures on the device...

I'm just afraid of a bug lurking somewhere that's just not as frequent on Gonk, but nevertheless present. But maybe you're right and it's just Windows IPC.
(Reporter)

Comment 7

5 years ago
> I'm just afraid of a bug lurking somewhere that's just not as frequent on Gonk, but nevertheless 
> present.

Ah, I see.  That's entirely possible, although I don't have any reason to believe that it's true, at this point.

Comment 8

5 years ago
Testing these on Windows w/latest mc in bug 820200 I didn't see any problems. I'm tempted to enable these when I push the fix for 820200.
(Reporter)

Comment 9

5 years ago
(In reply to Jim Mathies [:jimm] from comment #8)
> Testing these on Windows w/latest mc in bug 820200 I didn't see any
> problems. I'm tempted to enable these when I push the fix for 820200.

If it works, that's great.  If it doesn't work (or starts going even more randomorange than these tests normally go), I'm not going to lose sleep over keeping them disabled on Windows.

Updated

5 years ago
Depends on: 820200

Comment 10

5 years ago
We've only seen one windows test failure (bug 782633) on elm across a series of runs. So I think these are safe to turn on.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.