The default bug view has changed. See this FAQ.

package manifest includes files not compiled causing the installer to fail

RESOLVED FIXED in seamonkey2.13

Status

SeaMonkey
Installer
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Andrew Benton, Assigned: Andrew Benton)

Tracking

Trunk
seamonkey2.13
x86_64
Linux

SeaMonkey Tracking Flags

(seamonkey2.10+ fixed, seamonkey2.11 fixed, seamonkey2.12 fixed, seamonkey2.13 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
Created attachment 631653 [details]
Patch to fix the package manifest

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/15.0 Firefox/15.0a1
Build ID: 20120602100602

Steps to reproduce:

Compiled Seamonkey --with-system-nspr --with-system-nss --enable-system-sqlite and --disable-updater


Actual results:

When I came to cd suite/installer and run make it failed to create a tarball giving these errors:

mailKeysOError: package error or possible missing or unnecessary file: bin/libnspr4.so (package-manifest, 36).
Error: package error or possible missing or unnecessary file: bin/libplc4.so (package-manifest, 37).
Error: package error or possible missing or unnecessary file: bin/libplds4.so (package-manifest, 38).
Error: package error or possible missing or unnecessary file: bin/libmozsqlite3.so (package-manifest, 50).
message-Error: package error or possible missing or unnecessary file: bin/icons/updater.png (package-manifest, 355).
Error: package error or possible missing or unnecessary file: bin/libfreebl3.so (package-manifest, 411).
Error: package error or possible missing or unnecessary file: bin/libnss3.so (package-manifest, 412).
Error: package error or possible missing or unnecessary file: bin/libnssckbi.so (package-manifest, 413).
Error: package error or possible missing or unnecessary file: bin/libnssdbm3.so (package-manifest, 414).
Error: package error or possible missing or unnecessary file: bin/libnssutil3.so (package-manifest, 415).
Error: package error or possible missing or unnecessary file: bin/libsmime3.so (package-manifest, 416).
Error: package error or possible missing or unnecessary file: bin/libsoftokn3.so (package-manifest, 417).
Error: package error or possible missing or unnecessary file: bin/libssl3.so (package-manifest, 418).


Expected results:

It should have made a Seamonkey tarball

Comment 1

5 years ago
comm-release only accepts security or stability fixes. Please rebase your patch against trunk. Also I don't see the Firefox packager script having any special ifdefs for these. Possibly because we recently made packager errors fatal, does Firefox also do this?
(Assignee)

Comment 2

5 years ago
Created attachment 631762 [details] [diff] [review]
same patch against comm-central

(In reply to Philip Chee from comment #1)
> comm-release only accepts security or stability fixes. Please rebase your
> patch against trunk. Also I don't see the Firefox packager script having any
> special ifdefs for these. Possibly because we recently made packager errors
> fatal, does Firefox also do this?

No, the same bug exists in mozilla-central. I did submit a patch to fix the firefox installer when --enable-system-sqlite is used but no one resopnded so I didn't bother adding the nss and nspr portions. https://bugzilla.mozilla.org/show_bug.cgi?id=752895 I'll do that now
(In reply to Philip Chee from comment #1)
> comm-release only accepts security or stability fixes.

Fwiw for a patch like this that is not affecting our default ship-state I would normally be willing to accept (to make our linux distro maintainers lives easier).

That said, Andrew I'm going to defer on the Firefox review before I/Others grab this, please request review from me or :sgautherie once that bug passes.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

5 years ago
> I did submit a patch to fix the firefox installer
> when --enable-system-sqlite is used but no one responded
You need to flag your patch for review *and* make sure you fill in the reviewee field so someone will get bugmail. Otherwise nobody will notice your patch.

Updated

5 years ago
Duplicate of this bug: 763408
(Assignee)

Comment 6

5 years ago
Comment on attachment 631762 [details] [diff] [review]
same patch against comm-central

It seems Mike Hommey has accepted the patch to Mozilla central (bug 752895)
Attachment #631762 - Flags: review?(bugspam.Callek)

Updated

5 years ago
Assignee: installer → b3nton
Status: NEW → ASSIGNED
Version: SeaMonkey 2.10 Branch → Trunk

Updated

5 years ago
Blocks: 713134
Comment on attachment 631762 [details] [diff] [review]
same patch against comm-central

Review of attachment 631762 [details] [diff] [review]:
-----------------------------------------------------------------

approving for all branches, -- might need trivial bitrot fixups for non-trunk.
Attachment #631762 - Flags: review?(bugspam.Callek)
Attachment #631762 - Flags: review+
Attachment #631762 - Flags: approval-comm-release+
Attachment #631762 - Flags: approval-comm-beta+
Attachment #631762 - Flags: approval-comm-aurora+

Comment 8

5 years ago
Andrew, do you have checkin rights to the comm-* trees?
status-seamonkey2.10: --- → affected
status-seamonkey2.11: --- → affected
status-seamonkey2.12: --- → affected
status-seamonkey2.13: --- → affected
tracking-seamonkey2.10: --- → +
Keywords: checkin-needed
Target Milestone: --- → seamonkey2.13
(Assignee)

Comment 9

5 years ago
(In reply to Philip Chee from comment #8)
> Andrew, do you have checkin rights to the comm-* trees?

No
pushed directly to comm-release for our 2.10.1 build

http://hg.mozilla.org/releases/comm-release/rev/678cc53d0d42

Still needs checkin on all other branches.
status-seamonkey2.10: affected → fixed

Comment 11

5 years ago
> Still needs checkin on all other branches.
Pushed to all the other branches:
http://hg.mozilla.org/comm-central/rev/ce1107df35eb
http://hg.mozilla.org/releases/comm-aurora/rev/30ceab95f435
http://hg.mozilla.org/releases/comm-beta/rev/0f9abbfdb5a6

Thank you Andrew Benton!
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-seamonkey2.11: affected → fixed
status-seamonkey2.12: affected → fixed
status-seamonkey2.13: affected → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.