Native Fennec's input 'value' property doesn't change until user has pressed enter

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
5 years ago
a year ago

People

(Reporter: atul, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
In an input text field, the text field's "value" property doesn't seem to change until the user has pressed enter on the virtual keyboard. This means that even if keyup events are triggered (see bug 763201), JS won't be able to see what the user has typed so far.

I can submit a test case if it's determined that this bug isn't a duplicate.
Is this a regression? You testing on Nightly or Beta?
Keywords: testcase-wanted
OS: Mac OS X → Android
Hardware: x86 → ARM
Version: unspecified → Trunk
Works for me, using: http://people.mozilla.org/~mwargers/tests/forms/textinput/inputvalue_typing.html
Tested on the Galaxy Nexus, Galaxy SII and HTC Desire HD.

Please provide an url or testcase that shows the issue.
(Reporter)

Comment 3

5 years ago
Sorry, this is totally my bad--closing this as invalid. Sorry for wasting your time!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

5 years ago
By the way, I've just filed bug 764817, which is what I was actually experiencing when I mistakenly filed this bug. (I thought the input value wasn't being updated as the user typed, but in fact it's the case that changing an input field's value during touchstart seems to result in very odd behavior.)

Updated

5 years ago
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.