Web site causes Firefox to freeze up, use 100% CPU, and excessive memory

RESOLVED INVALID

Status

()

Core
JavaScript Engine
RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: Timothy Miller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [js:inv:p3])

(Reporter)

Description

6 years ago
Try going to this web site:

https://lawson.sdhc.k12.fl.us/lawson/portal/

When I do, Firefox uses 100% CPU, eats up memory, and freezes.  Eventually, it will pop up a box telling me that there's an unresponsive script, but I can't click the alert box.  Windows will tell me that the app is unresponsive and ask me if I want to end the process.  The process won't end.  Basically, this web site completely hoses up Firefox.

There is no problem with this web site in IE 8.

Now, maybe this web site is broken and IE-specific.  But that's no excuse for for Firefox eating up memory and CPU time and freezing up and not letting me kill the script.  It should just fail gracefully.

And, of course, if I go into Task Manager and kill Forefix and then restart Firefox, it reloads the page, so I can't use Firefox anymore.  (I'll try to figure out how to start it in a safe mode or something.)
(Reporter)

Comment 1

6 years ago
Same problem in Nightly and Nightly on Mac.
(Reporter)

Comment 2

6 years ago
Actually, it CRASHES the Nightly.  Even if this is IE-specific, it still shouldn't crash Firefox.
I get a slow script warning for
Script: https://lawson.sdhc.k12.fl.us/lawson/portal/common.js:140

I can stop the hang if I stop this script. This is no regression, i tested back to builds from 2010-04-01
Firefox13 crashes 1s after showing the slow script warning (no crashing thread identified; corrupt dump).

This looks like a bug in the page...
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Component: General → JavaScript Engine
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → general
(Reporter)

Comment 4

6 years ago
Seems like one of countless broken IE specific pages.  That isn't your problem.

It still should not crash Firefox.  When Firefox crashes, it's a bug in the browser.  This should fail, but fail gracefully.
If you have `javascript.options.strict` set to `true`, try setting it to `false` (bug 756150)
Whiteboard: [js:p1]
I get a slow script warning too, not a crash. The site doesn't work in Chrome, either, although they handle it more gracefully (for other reasons).
Whiteboard: [js:p1] → [js:inv:p3]

Comment 7

5 years ago
The website only works on IE.
For Nightly, Beta and Chrome, it shows:
"The Lawson Portal does not support this browser: Netscape.
Use the Portal Installation Guide to determine the system requirements needed for running the Lawson Portal."

Resolved Invalid?
Yes. I filed bug 916623 for tech evangelism.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.