Note: There are a few cases of duplicates in user autocompletion which are being worked on.

MD5 results calculated differently between Chrome and Firefox

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Chua Chee Wee, Unassigned)

Tracking

16 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

9.82 KB, application/octet-stream
Details
(Reporter)

Description

5 years ago
Created attachment 631853 [details]
md5.js

User Agent: Mozilla/5.0 (Windows NT 6.0; Win64; x64; rv:16.0) Gecko/16.0 Firefox/16.0a1
Build ID: 20120610030528

Steps to reproduce:

1. Created a free account on www.tunnelbroker.net using Firefox 16.0a1.
2. According to tunnelbroker.net, the account created is usable on other sites, eg, http://ipv6.he.net/certification/
3. However, with Firefox, using the same account credentials created in Step 1, I can't login to http://ipv6.he.net/certification/.
4. Tracking down the issue leads me to the MD5 calculations at http://www.tunnelbroker.net/js/md5.js
5. It seems that if you enter javascript:alert(MD5("1")); at the URL after going to http://www.tunnelbroker.net, Chrome and Firefox gives different results.



Actual results:

In Firefox, javascript:alert(MD5("1")); gives a different result each time.
In Chrome, javascript:alert(MD5("1")); always returns c4....9b



Expected results:

It should return c4....9b.
This is WFM using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120611030526 and using Scratchpad (Shift+F4) in Step 5.
(Reporter)

Comment 2

5 years ago
Seems to be a plugin issue. When I run in safe mode, it works!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.