mailto links don't work with url-encoded non-ASCII characters

RESOLVED WORKSFORME

Status

()

Core
Internationalization
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: D, Unassigned)

Tracking

({regression})

13 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 631857 [details]
Test case

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1
Build ID: 20120606010119

Steps to reproduce:

Since Firefox 13, click on a mailto link with url-encoded non-ASCII characters


Actual results:

It does nothing


Expected results:

It should an Outlook window
(Reporter)

Updated

6 years ago
Attachment #631857 - Attachment mime type: text/plain → text/html
(Reporter)

Comment 1

6 years ago
Seems Firefox doesn't decode the URL when there's url-encoded non-ASCII characters.
(Reporter)

Updated

6 years ago
Keywords: regression
(Reporter)

Comment 2

6 years ago
For me no Window opens, for some in the test case, the body is stripped.

Comment 3

6 years ago
Both links are opened in Thunderbird here, but the first one doesn't have a body.

Comment 4

6 years ago
(In reply to Darren Kalck [:D-Kalck] from comment #2)
> For me no Window opens, for some in the test case, the body is stripped.

I agree.  It is stripped, as well, for me, of the body.
(Reporter)

Comment 5

6 years ago
After a further research, it seems Firefox treat encoded characters as UTF-8, since %E2%82%AC work but not %80.

Comment 6

6 years ago
(In reply to Darren Kalck [:D-Kalck] from comment #5)
> After a further research, it seems Firefox treat encoded characters as
> UTF-8, since %E2%82%AC work but not %80.

I agree.  It does seem this way about how Firefox treats encoded characters as UTF-8 in this type of case.
(Reporter)

Comment 7

6 years ago
Could it be related to bug 647403 and the removal of network.standard-url.encode-query-utf8 ?

Comment 8

2 years ago
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
Version 	46.0a1
Build ID 	20160112030207
Channel 	nightly

Thank you for taking time to report this.
Are you still able to reproduce this in the latest version ? I cannot reproduce in the current version.
Component: Untriaged → Internationalization
Flags: needinfo?(d-kalck)
Product: Firefox → Core

Comment 9

2 years ago
It is not reproducible. Closing this as works for me.
Please feel free to reopen this bug if it still reproduces in the latest versions. Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Updated

2 years ago
Flags: needinfo?(d-kalck)
You need to log in before you can comment on or make changes to this bug.