createEvent creates a KeyEvent for any event type

VERIFIED DUPLICATE of bug 35377

Status

()

Core
DOM: Events
VERIFIED DUPLICATE of bug 35377
17 years ago
17 years ago

People

(Reporter: Vladimir Ermakov, Assigned: joki (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
event = document.createEvent("MouseEvent");
alert(event);

The following code shows "object KeyEvent" In the alert box.
I'll attach the testcase
(Reporter)

Comment 1

17 years ago
Created attachment 31165 [details]
testcase
(Reporter)

Updated

17 years ago
OS: Windows 98 → All

Comment 2

17 years ago
The test case shows a return of null for me in Moz 0.8.1 on Linux.

According to the spec, the string passed to createEvent() should be plural, by
the way: createEvent("MouseEvents"), createEvent("UIEvents") etc.
(Assignee)

Comment 3

17 years ago
It doesn't really create a KeyEvent, that's just the javascript class typing at 
the moment, dupe of 35377.  It has the appropriate properties.  The plural 
string part is in 77251.

*** This bug has been marked as a duplicate of 35377 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

17 years ago
Verifying duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.