transition triggered by :hover reverses once the element moves out from under the mouse pointer

RESOLVED DUPLICATE of bug 652767

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 652767
5 years ago
4 years ago

People

(Reporter: Daniel Desira, Unassigned)

Tracking

16 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 632002 [details]
demo showing jerky border transition

Stanzas in this demo move smoothly when hovered upon in Chrome and Opera while the transition tends to be jerky on desktop Firefox. Shows an issue with the current CSS3 transitions implementation in Gecko.
Attachment #632002 - Attachment mime type: text/plain → text/html
Hmm.  Which part is jerky?  I can only reproduce the jerkiness if I put my mouse somewhere that's inside the stanza at the old location but not the new one.  Are you seeing something different?
(Reporter)

Comment 2

5 years ago
That and also when I leave the mouse at a position half way the position of the full transition
Sure.  But that's expected behavior here, no?  If the stanza moves so that it's no longer hovered then the style stops applying and the transition is reversed.

What you see in Chrome and Opera is that they simply don't update hover styles correctly (in general; it's not a transition-specific issue) unless the mouse is moved, so you end up in a situation where the stanza is not hovered but still has the hover styles applying; as soon as you move the mouse by even a pixel the text moves back to its original position.
Component: General → Style System (CSS)
QA Contact: general → style-system
Summary: transition of border relatively jerky → transition triggered by :hover reverses once the element moves out from under the mouse pointer
Whiteboard: DUPEME
Maybe duplicate of bug 652767, or maybe duplicate of something just about :hover since this doesn't really require transitions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 652767

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.