hang opening new browser from mail compose

RESOLVED FIXED in mozilla0.9

Status

()

Core
XBL
P1
critical
RESOLVED FIXED
17 years ago
5 years ago

People

(Reporter: Chris Waterson, Assigned: David Hyatt)

Tracking

({hang, regression})

Trunk
mozilla0.9
hang, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: critical for mozilla 0.9)

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
SUMMARY

Mozilla hangs in an infinite loop when opening a new browser window from the
mail compose window.

To Reproduce:

1. Start mozilla.
2. Open a mail compose window (e.g., by pressing Ctrl+M)
3. Open a new browser window by pression Ctrl+N in the mail compose window

Expected:

Browser window opens.

Action:

App hangs, CPU pegged.
(Reporter)

Updated

17 years ago
Severity: normal → critical
Keywords: hang, mozilla0.9, nsCatFood, regression
(Reporter)

Comment 1

17 years ago
Created attachment 31184 [details]
stack trace at hang; infinite loop in nsXBLWindowHandler::WalkHandlersInternal
(Reporter)

Comment 2

17 years ago
Created attachment 31185 [details]
stack trace; hang at nsXBLWindowHandler::WalkHandlersInternal
(Reporter)

Comment 3

17 years ago
Aw crap, ignore the first stack trace. I fat-fingered emacs. The second stack
trace has the goods; specifically, hanging in
nsXBLWindowHandler::WalkHandlersInternal().

Comment 4

17 years ago
However, when I go to File Menu -> New -> Navigator Window, I cannot bring up a
new navigator window.  Another bug???

Comment 5

17 years ago
Is this a dup of Bug 75517 ??

Comment 6

17 years ago
*** Bug 75517 has been marked as a duplicate of this bug. ***
OS: Windows 2000 → All
Hardware: PC → All
Whiteboard: critical for mozilla 0.9

Comment 7

17 years ago
targetting moz0.9/p1
Priority: -- → P1
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 8

17 years ago
Created attachment 31540 [details] [diff] [review]
Oops.  Continue was not the right thing to do here.
(Assignee)

Comment 9

17 years ago
Created attachment 31541 [details] [diff] [review]
Also adding menu assertion to help XUL authors.
(Reporter)

Comment 10

17 years ago
sr=waterson. thanks for the speedy service!

Comment 11

17 years ago
a= asa@mozilla.org for checkin to 0.9

Does this still need a r= or is it ready to go?
(Assignee)

Comment 12

17 years ago
Fixed the hang and added assertions.  Note that the mailcompose window is 
missing the <command> element for new navigator window, and so a separate bug 
should be filed against the mailcompose window for that issue.  

With my patch CTRL+N will no longer hang, but like the menu item, it won't work.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 13

17 years ago
*** Bug 76764 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
David that missing <command> issue has been fixed by me in bug 76764.

You need to log in before you can comment on or make changes to this bug.