update-named issue: "service named reload" does not load new SOA/zone information

RESOLVED FIXED

Status

Cloud Services
Operations
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: atoll, Assigned: atoll)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

Our nameservers stopped loading new zone data after an update-named change from "service named restart" to "service named reload" recently.

Per cronmail, everything worked just fine:

Fetching external item into 'zones'
U    zones/mozilla.com/svc/phx1
U    zones/mozilla.com/svc/SOA
Updated external to revision 40464.
...
Reloading named: [  OK  ]

But it simply didn't load the new SOA data until a "service named restart" was run manually on the server.

This affects all nameservers in SCL2 and PHX1.
Whiteboard: [qa-]
Also ignores failure result code from named reload:

Reloading named:                                           [FAILED]
After reload:
total 56
...

Implementing puppet code to test sysadmins/dnsconfig-weave/bin/update-named.stage on ns1/2.scl2.stage.svc
Assignee: nobody → rsoderberg
Created attachment 638596 [details] [diff] [review]
use rndc freeze+reload+thaw instead of rndc reload, so that dynamic zones are reloaded as well

Root cause is that some or all of our zones are considered dynamic, and so "rndc reload" only reloads non-dynamic zones. Attempting to "rndc reload soatest.svc.mozilla.com" logs:

rndc: 'reload' failed: dynamic zone

to ensure that we reload zones correctly, the following alteration to update-named.stage repairs the issue:

-          /sbin/service named reload
+          "$RNDC freeze; $RNDC reload; $RNDC thaw;"

This patch implements the above change, and is confirmed working in stage using "soatest.svc.mozilla.com" zone which exists only in stage configs.
Blocks: 770422
Blocks: 770565
deployed to SCL2, PHX1
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.