Closed Bug 763740 Opened 8 years ago Closed 8 years ago

Allow launching of natively installed webapps from launch() method in mozapps API - Mac OS X

Categories

(Firefox Graveyard :: Web Apps, defect, P1)

x86
macOS
defect

Tracking

(blocking-kilimanjaro:+)

RESOLVED DUPLICATE of bug 772600
Firefox 16
blocking-kilimanjaro +

People

(Reporter: dwalkowski, Assigned: dwalkowski)

References

Details

Attachments

(1 file)

In addition to determining which webapps have been natively installed (bug 762698), users should be able to launch native apps from within the html webapps dashboard.
Depends on: 756308, 762698
Attached patch proposed patchSplinter Review
This patch extends the patch in 762698 to allow launching of natively installed webapps from within privileged dashboards.
Attachment #632047 - Flags: review?
Summary: launch natively installed webapps from within html dashboard → Launch natively installed webapps from within html dashboard - Mac OS X
Blocks: 745924
Component: DOM: Mozilla Extensions → Web Apps
Product: Core → Firefox
QA Contact: general → webapps
Summary: Launch natively installed webapps from within html dashboard - Mac OS X → Allow launching of natively installed webapps from launch() method in mozapps API - Mac OS X
blocking-kilimanjaro: --- → ?
Nominating for k9o - prerequsite bug needed to be implemented to support launching of native web apps on mac.
blocking-kilimanjaro: ? → +
Priority: -- → P1
Target Milestone: --- → Firefox 16
Assignee: nobody → dwalkowski
Attachment #632047 - Flags: review? → review?(felipc)
I would like this changes to commit asap for the newnewtab project. 
Also, I would suggest a cleanup followup work to move platform specific manipulation into a single module: see comments to bug 763789.
for testing purposes, we can tell apps we launch to quit without adding additional API by using the command line:
'osascript -e \'tell application "TextEdit" to quit\''
for example
Status: NEW → ASSIGNED
QA Contact: jsmith
Attachment #632047 - Flags: review?(felipc)
Fixed by bug 772600
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Too many bugs. I'm duping against that one so I can follow this easier, as that's the main bug that has the patch for all of the parts.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 772600
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.