Include our video/x-vidx plugin in Plugin Finder Service

RESOLVED WONTFIX

Status

Toolkit Graveyard
Plugin Finder Service
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: Kyrylo V. Polezhaiev, Assigned: Tomcat)

Tracking

({qawanted})

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1163.0 Safari/537.1

Steps to reproduce:

On visiting page with content of MIME type video/x-vidx or embedded application/x-vidxmediaplayer.


Actual results:

We have to manually download and run installer.


Expected results:

We would like to include our plugin into the list of PFS to allow our users to automatically install our plugin.
We support only Windows platform. Our installer located at http://vidx-codec.com/setup/vidx-downloader.exe (Will be moved to just vidx-codec.com/setup).
Component: Plug-ins → Plugins
Product: Core → addons.mozilla.org
QA Contact: plugins → plugin-listings

Updated

5 years ago
Summary: We would like to include our plugin in Plugin Finder Service. → Include our video/x-vidx plugin in Plugin Finder Service
(Assignee)

Updated

5 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 1

5 years ago
its now on plugincheck stage.

Steps to stage:
-> Go to plugins.stage.mozilla.com (accept the cert) its needed to get results on the pluginstage site
-> go to https://www.allizom.org/en-US/plugincheck/ and check the result for your plugin

if all is ok i can push it to the production site
Assignee: nobody → cbook
(Assignee)

Updated

5 years ago
Flags: needinfo?(polezhaiev)
(Assignee)

Comment 2

5 years ago
raymond, also if you could do the QA check it would be great, thanks!
Keywords: qawanted
(Reporter)

Comment 3

5 years ago
Hello, will share test page soon.
Flags: needinfo?(polezhaiev)
(Assignee)

Comment 4

5 years ago
also pushed now to production since also my own tests passed
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

5 years ago
Hi, test page is now available at http://open-light.org/
(Assignee)

Comment 6

5 years ago
ah ok, the change i did was for plugincheck, and added this.

for Pluginfinder Service this information is needed:

* Name of the plugin (Windows Media Player 11/Vista)?
* GUID
* Version string
* URL of the icon to be used for the plugin installer UI
* Location of the XPI that the browser should install.
* Does the installer show its own UI?
* URL for manual installation if the auto-install fails.
* License URL
* Does it require a browser restart post-installation?
* Mime types it needs to be associated with.
* Operating systems (in UA string) that should be given WMP 11.
* Versions of Firefox that are compatible (if not all)?
Status: RESOLVED → REOPENED
Component: Plugins → Plugin Finder Service
Product: addons.mozilla.org → Toolkit
Resolution: FIXED → ---
(Assignee)

Updated

5 years ago
Flags: needinfo?(polezhaiev)
(Reporter)

Comment 7

5 years ago
1. Name of the plugin (Windows Media Player 11/Vista)? --- VidX Web Player
2. GUID --- ca7f8e48-84e4-5cae-9e3b-24c906e66a0b
3. Version string --- 2.1.0
4. URL of the icon to be used for the plugin installer UI - what size and format. --- http://vidx-codec.com/setup-ff/install.ico, 32x32, ico format. 
5. Location of the XPI that the browser should install - Not XPI, it's an executable file here is URL: http://vidx-codec.com/setup-ff/vidx-downloader.exe  
6. Does the installer show its own UI? --- yes
7. URL for manual installation if the auto-install fails. --- http://vidx-codec.com/setup/vidx-downloader.exe  
8. License URL --- http://vidx-codec.com/terms.html
9. Does it require a browser restart post-installation? Yes
10. Mime types it needs to be associated with. --- application/x-vidxwebplayer, video/x-vidx
11. Operating systems (in UA string) that should be given WMP 11 --- We do not need WMP for our plugin. Plugin works on Windows XP, Windows 7, Windows 7 x64
12. Versions of Firefox that are compatible (if not all)? - 13,14, 15, 16
Flags: needinfo?(polezhaiev)
(Assignee)

Comment 8

5 years ago
thanks, working on that
(Assignee)

Comment 9

5 years ago
Created attachment 684405 [details] [diff] [review]
patch to integrate x-vidx

cc'ing kev and clouser. Not sure who is the best person to review and since this is my first addion to pfs ever feel free to give any feedback!
Attachment #684405 - Flags: review?(kev)
Attachment #684405 - Flags: review?(clouserw)

Comment 10

5 years ago
Comment on attachment 684405 [details] [diff] [review]
patch to integrate x-vidx

I'm going to r- this, as there are a few things we'd need to see corrected to provide a match with video/x-vidx. Those things are as follows:

- Use of meta-installer - the linked download needs to be the full installer. Using a meta-installer means that the payload can be changed arbitrarily, and policy requires that any change to the installer is reviewed (and the binary file hash/version updated). Please provide a link to the full installer vs. a stub/meta installer.
- Unsigned installer package: The installer is not signed with an authenticode cert, which it must be. Please ensure that the full installer is signed.
- No terms of use/privacy policy: The terms of use referenced by the installer refers to the website, not the application that's being installed. In order for this to be added to PFS, the terms of use and the privacy policy for the software being installed should be clearly laid out.

Once these changes have been made, we can re-review the submission for inclusion. Tomcat, have we also run this through QA/perf/leak testing?

Thanks folks, and if there are any questions, please let me know.
Attachment #684405 - Flags: review?(kev) → review-
Attachment #684405 - Flags: review?(clouserw)
(Assignee)

Comment 11

5 years ago
any updates here?
(Reporter)

Comment 12

5 years ago
Hi Guys,

I have been silent for a while as I have ran into some development issues. I will provide a path to the actual installer, which will be signed as well as terms of use for the installer itself.

Hopefully this will happen in a matter of days.
Actually... We're no longer adding entries to the plugin finder service (nor have we added any new entries in quite some time).

I'd suggest that you instead provide guidance to sites using your plugin on how to provide fallback content (for browsers without your plugin installed) which directs users to some page explaining what your plugin does and how to install it.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WONTFIX
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.