[Ratings] Allow developers to edit their ratings

RESOLVED FIXED in 2012-07-26

Status

P3
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: cvan, Assigned: basta)

Tracking

2012-07-26
Points:
---

Details

(Reporter)

Description

6 years ago
We allow developers to edit reviews on AMO: https://github.com/mozilla/zamboni/blob/master/apps/reviews/views.py#L204

We should allow the same on the Marketplace. Use some AJAX, and let's make it happen, cap'n!
(Reporter)

Comment 1

6 years ago
https://github.com/mozilla/zamboni/commit/e4cf2de

A few outstanding issues I've noticed:

- missing error handling when I enter an empty review ('', ' ', '\n', etc.) or if there are > 150 characters.
- missing the character counter like we have for submission (150 characters or fewer).
- if the review is exactly the same do not save another.
- if I edit the review and there was a developer reply, you no longer see the developer reply since it corresponded to a separate review!
- when I click Cancel it takes two clicks to dismiss the modal.
- clean up margins, buttons, etc.
Target Milestone: --- → 2012-06-21
(Reporter)

Comment 2

6 years ago
When I edit a review it says "Your review was successfully added!" http://cl.ly/0p1s0Q3h1P2T2m082835
(Reporter)

Comment 3

6 years ago
Also, when I try to edit a reply it 403s on me because that's effectively the same as writing a *new* review for my own app.
(Reporter)

Updated

6 years ago
Assignee: thepotch → nobody
Priority: -- → P3
(Reporter)

Comment 4

6 years ago
https://github.com/cvan/zamboni/commit/f1b25e2

I think Basta has fixed pretty much all these issues.
Assignee: nobody → mattbasta
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: 2012-06-21 → 2012-07-26

Comment 5

6 years ago
(In reply to Chris Van Wiemeersch [:cvan] from comment #3)
> Also, when I try to edit a reply it 403s on me because that's effectively
> the same as writing a *new* review for my own app.

[16:49:45.899] POST https://marketplace-dev.allizom.org/en-US/app/seevans-underworld-adventur-11/reviews/add [HTTP/1.1 403 FORBIDDEN 57ms]
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

6 years ago
Done

https://github.com/mozilla/zamboni/commit/2cf81d1b8bd7e269445d979aa6690aafb3902da4
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Duplicate of this bug: 777276
You need to log in before you can comment on or make changes to this bug.