Closed Bug 763818 Opened 7 years ago Closed 7 years ago

Intermittent test_expandosharing.xul | Exited with code 253 during test run [@ js::GCMarker::processMarkStackTop] after Assertion failure: (obj2)->compartment()->isCollecting()

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 763381

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: assertion, intermittent-failure, Whiteboard: [js:t])

https://tbpl.mozilla.org/php/getParsedLog.php?id=12573104&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound debug test mochitest-other on 2012-06-11 19:56:56 PDT for push 038ab46bfb08
slave: talos-r3-xp-018

11658 INFO TEST-PASS | chrome://mochitests/content/chrome/js/xpconnect/tests/chrome/test_expandosharing.xul | document.domain should have no effect here
Assertion failure: (obj2)->compartment()->isCollecting(), at e:/builds/moz2_slave/m-in-w32-dbg/build/js/src/gc/Marking.cpp:1142
WARNING: shutting down early because of crash!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/plugins/ipc/PluginModuleChild.cpp, line 699
WARNING: plugin process _exit()ing: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/plugins/ipc/PluginModuleChild.cpp, line 664
NPP_Destroy
NPP_Destroy
NPP_Destroy
NPP_Destroy
NPP_Destroy
nsStringStats
 => mAllocCount:            119
 => mReallocCount:            1
 => mFreeCount:              54  --  LEAKED 65 !!!
 => mShareCount:            129
 => mAdoptCount:              0
 => mAdoptFreeCount:          0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/js/xpconnect/tests/chrome/test_expandosharing.xul | Exited with code 253 during test run
INFO | automation.py | Application ran for: 0:04:45.500000
INFO | automation.py | Reading PID log: c:\docume~1\cltbld\locals~1\temp\tmpxecol1pidlog
==> process 4072 launched child process 3420
==> process 4072 launched child process 3584
==> process 4072 launched child process 1388
==> process 4072 launched child process 936
==> process 4072 launched child process 3740
INFO | automation.py | Checking for orphan process with PID: 3420
INFO | automation.py | Checking for orphan process with PID: 3584
INFO | automation.py | Checking for orphan process with PID: 1388
INFO | automation.py | Checking for orphan process with PID: 936
INFO | automation.py | Checking for orphan process with PID: 3740
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32-debug/1339461624/firefox-16.0a1.en-US.win32.crashreporter-symbols.zip
PROCESS-CRASH | chrome://mochitests/content/chrome/js/xpconnect/tests/chrome/test_expandosharing.xul | application crashed (minidump found)
Crash dump filename: c:\docume~1\cltbld\locals~1\temp\tmpc9-vhe\minidumps\ca4fd7b8-559c-46ef-b504-ddc72ac7ceb6.dmp
Operating system: Windows NT
                  5.1.2600 Service Pack 2
CPU: x86
     GenuineIntel family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXCEPTION_ACCESS_VIOLATION_WRITE
Crash address: 0x0

Thread 0 (crashed)
 0  mozjs.dll!js::GCMarker::processMarkStackTop(js::SliceBudget &) [Marking.cpp:038ab46bfb08 : 1111 + 0x3b]
    eip = 0x0106b5a1   esp = 0x0012d138   ebp = 0x0012d160   ebx = 0x1dc66040
    esi = 0x10261440   edi = 0x15a383d0   eax = 0x00000000   ecx = 0xf42291b0
    edx = 0x10361f48   efl = 0x00210206
    Found by: given as instruction pointer in context
 1  mozjs.dll!js::GCMarker::drainMarkStack(js::SliceBudget &) [Marking.cpp:038ab46bfb08 : 1224 + 0x7]
    eip = 0x0106bb18   esp = 0x0012d168   ebp = 0x0012d17c
    Found by: call frame info
 2  mozjs.dll!IncrementalMarkSlice [jsgc.cpp:038ab46bfb08 : 3567 + 0x12]
    eip = 0x00ea79f7   esp = 0x0012d184   ebp = 0x0012d1bc
    Found by: call frame info
 3  mozjs.dll!GCCycle [jsgc.cpp:038ab46bfb08 : 3722 + 0xc]
    eip = 0x00ea7cb2   esp = 0x0012d1c4   ebp = 0x0012d21c
    Found by: call frame info
 4  mozjs.dll!Collect [jsgc.cpp:038ab46bfb08 : 3828 + 0x1a]
    eip = 0x00ea8047   esp = 0x0012d224   ebp = 0x0012d254
    Found by: call frame info
 5  mozjs.dll!js::GCSlice(JSRuntime *,js::JSGCInvocationKind,js::gcreason::Reason) [jsgc.cpp:038ab46bfb08 : 3858 + 0x1f]
    eip = 0x00ea81b3   esp = 0x0012d25c   ebp = 0x0012d270
    Found by: call frame info
 6  mozjs.dll!js::NotifyDidPaint(JSRuntime *) [jsfriendapi.cpp:038ab46bfb08 : 724 + 0x9]
    eip = 0x00e804c0   esp = 0x0012d278   ebp = 0x0012d298
    Found by: call frame info
 7  xul.dll!nsXPConnect::NotifyDidPaint() [nsXPConnect.cpp:038ab46bfb08 : 2691 + 0x11]
    eip = 0x01e48d42   esp = 0x0012d2a0   ebp = 0x0012d2a4
    Found by: call frame info
 8  xul.dll!PresShell::DidPaint() [nsPresShell.cpp:038ab46bfb08 : 6985 + 0x8]
    eip = 0x015e7c92   esp = 0x0012d2ac   ebp = 0x0012d2c0
https://tbpl.mozilla.org/php/getParsedLog.php?id=12557408&tree=Try
Rev3 Fedora 12 try debug test mochitest-other on 2012-06-11 10:54:47 PDT for push 184d0aa0c1b4
slave: talos-r3-fed-008
Terrence/Luke, please may one of you take a look at this - it has been pretty recently introduced.
The crashes start at 6-11, so this seems like the same underlying issue as bug 757795.
I think this should be fixed by bug 763381. It looks like it hasn't happened since that landed. The Fx-Team crash happened before the patch merged to that tree, and I suspect the same is true of the Ionmonkey crash.
Whiteboard: [orange] → [js:t][orange]
After two weekdays of no crashes, I think it's safe to call it a dupe.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 763381
Whiteboard: [js:t][orange] → [js:t]
You need to log in before you can comment on or make changes to this bug.