Fennec hard locks Android

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
--
major
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: Wesley Hardman, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
When scrolling quickly on long pages, Fennec lags and jumps to the end of the scroll.  The following is also logged to Logcat a few times.

06-12 12:40:28.868 W/SharedBufferStack( 2285): waitForCondition(LockCondition) timed out (identity=53, status=0). CPU may be pegged. trying again.

Every so often Fennec will lock up Android completely and I am forced to remove the battery and restart the phone.  The previous line is repeated continuously until the phone is rebooted.  This happened to me a few times a couple months ago, but then it stopped occurring.  It occurred again just now and I was able to trigger it and grab a Logcat of it happening.


Mozilla/5.0 (Android; Mobile; rv:16.0) Gecko/16.0 Firefox 16.0a1 - 20120612030527
on HTC Evo 4G (Android 2.2)

STR: 

1. Launch Fennec.
2. Open a webpage which is long and has lots of content (I.E. http://dslreports.com/)
3. Scroll (Fling) quickly up and down the page.

Expected Result:
Page should scroll without locking Android.

Actual Result:
Fennec will occasionally lockup, forcing Android to be restarted.
(Reporter)

Updated

6 years ago
(Reporter)

Comment 1

6 years ago
Created attachment 632309 [details]
Logcat.

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Marcia, is your EVO 4G updated from Android 2.2 to Android 2.3? Do you see this on your device?
(Reporter)

Comment 3

6 years ago
Has there been any progress on this?  I have been seeing it more and more often.  It has also started happening on page load as well making it difficult to use Fennec.
There's nothing really actionable here as we don't have any further steps to reproduce.
(Reporter)

Comment 5

6 years ago
I've been able to get this to happen quite frequently.  Is there anything I can do to help troubleshoot it?

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.