Smilies should have tooltips displaying the untransformed text

RESOLVED FIXED in Thunderbird 17.0

Status

Thunderbird
Instant Messaging
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Mook, Assigned: mconley)

Tracking

Trunk
Thunderbird 17.0

Thunderbird Tracking Flags

(thunderbird15 fixed, thunderbird16 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
This is the IM equivalent of bug 234638.
When my mouse hovers over smilies/emoticons, it would be nice to show the original text as a tooltip.  It seems like the images already have a title= attribute, it's just not set up to display them at the moment.

(This was mostly tested against IRC.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

5 years ago
Assignee: nobody → mconley
If it is of any help, the code handling this in Instantbird is at http://lxr.instantbird.org/instantbird/source/instantbird/content/instantbird.js#63 and Thunderbird already has an equivalent at http://mxr.mozilla.org/comm-central/source/mail/base/content/mailWindow.js#559

So fixing this may just be a matter of adding a correct contenttooltip attribute on new conversation bindings, as the imconversation binding seems to expected it: http://mxr.mozilla.org/comm-central/source/mail/components/im/content/imconversation.xml#26
(Assignee)

Comment 2

5 years ago
Created attachment 643849 [details] [diff] [review]
Patch v1
Attachment #643849 - Flags: review?(florian)
Comment on attachment 643849 [details] [diff] [review]
Patch v1

>diff --git a/mail/components/im/content/chat-messenger-overlay.js b/mail/components/im/content/chat-messenger-overlay.js
>--- a/mail/components/im/content/chat-messenger-overlay.js
>+++ b/mail/components/im/content/chat-messenger-overlay.js
>@@ -535,16 +535,17 @@ var chatHandler = {
>     else if (item.localName == "imconv") {
>       let convDeck = document.getElementById("conversationsDeck");
>       if (!item.convView) {
>         let conv = document.createElement("imconversation");
>         convDeck.appendChild(conv);
>         conv.conv = item.conv;
>         conv.tab = item;
>         conv.setAttribute("contentcontextmenu", "chatConversationContextMenu");
>+        conv.setAttribute("tooltip", "aHTMLTooltip");

Have you tried using the contenttooltip attribute instead of tooltip, so that the tooltip is only applied to the content area, and not the whole conversation binding?
(Assignee)

Comment 4

5 years ago
(In reply to Florian Quèze from comment #3)
> Comment on attachment 643849 [details] [diff] [review]
> Patch v1
> 
> >diff --git a/mail/components/im/content/chat-messenger-overlay.js b/mail/components/im/content/chat-messenger-overlay.js
> >--- a/mail/components/im/content/chat-messenger-overlay.js
> >+++ b/mail/components/im/content/chat-messenger-overlay.js
> >@@ -535,16 +535,17 @@ var chatHandler = {
> >     else if (item.localName == "imconv") {
> >       let convDeck = document.getElementById("conversationsDeck");
> >       if (!item.convView) {
> >         let conv = document.createElement("imconversation");
> >         convDeck.appendChild(conv);
> >         conv.conv = item.conv;
> >         conv.tab = item;
> >         conv.setAttribute("contentcontextmenu", "chatConversationContextMenu");
> >+        conv.setAttribute("tooltip", "aHTMLTooltip");
> 
> Have you tried using the contenttooltip attribute instead of tooltip, so
> that the tooltip is only applied to the content area, and not the whole
> conversation binding?

Yes, but setting this attribute did not seem to have any effect.
(Assignee)

Comment 5

5 years ago
Created attachment 643909 [details] [diff] [review]
Patch v2

Thanks Florian - as you suggested, I've switched to using contenttooltip for imconversations.
Attachment #643849 - Attachment is obsolete: true
Attachment #643849 - Flags: review?(florian)
Attachment #643909 - Flags: review?(florian)
Attachment #643909 - Flags: review?(florian) → review+
(Assignee)

Updated

5 years ago
Attachment #643909 - Flags: approval-comm-beta?
Attachment #643909 - Flags: approval-comm-aurora?
(Assignee)

Updated

5 years ago
tracking-thunderbird15: --- → ?
tracking-thunderbird16: --- → ?
Comment on attachment 643909 [details] [diff] [review]
Patch v2

Yeah, I really think we want to have this on aurora/beta.
Attachment #643909 - Flags: approval-comm-beta?
Attachment #643909 - Flags: approval-comm-beta+
Attachment #643909 - Flags: approval-comm-aurora?
Attachment #643909 - Flags: approval-comm-aurora+
(Assignee)

Comment 7

5 years ago
comm-central: https://hg.mozilla.org/comm-central/rev/239e6b72515e
comm-aurora: https://hg.mozilla.org/releases/comm-aurora/rev/c4ae50a781db
comm-beta: https://hg.mozilla.org/releases/comm-beta/rev/adb23200a7e8
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-thunderbird15: --- → fixed
status-thunderbird16: --- → fixed
tracking-thunderbird15: ? → ---
tracking-thunderbird16: ? → ---
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 17.0
(Assignee)

Comment 8

5 years ago
Backed out of comm-beta since we landed on a SeaMonkey relbranch (oops).

Re-landed on comm-beta as: https://hg.mozilla.org/releases/comm-beta/rev/6d8e097e1f9b
You need to log in before you can comment on or make changes to this bug.