Last Comment Bug 764285 - Use virtual keycodes in SDK for Mac instead of defined by ourselves
: Use virtual keycodes in SDK for Mac instead of defined by ourselves
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Cocoa (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- normal (vote)
: mozilla16
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan)
:
: Markus Stange [:mstange]
Mentors:
Depends on:
Blocks: 680830 768736
  Show dependency treegraph
 
Reported: 2012-06-13 00:30 PDT by Masayuki Nakano [:masayuki] (Mozilla Japan)
Modified: 2012-07-04 06:37 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
part.1 Use virtual keycodes defined in SDK (27.46 KB, patch)
2012-06-13 01:04 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan)
smichaud: review+
Details | Diff | Splinter Review
part.2 Use naming rules of virtual keycodes in SDK for defining undefined keycode (10.64 KB, patch)
2012-06-13 01:05 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan)
smichaud: review+
Details | Diff | Splinter Review

Description Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-06-13 00:30:45 PDT

    
Comment 1 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-06-13 01:04:14 PDT
Created attachment 632591 [details] [diff] [review]
part.1 Use virtual keycodes defined in SDK

It doesn't make sense to redefine keycode by our naming rules.
Comment 2 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-06-13 01:05:42 PDT
Created attachment 632592 [details] [diff] [review]
part.2 Use naming rules of virtual keycodes in SDK for defining undefined keycode

Use same naming rules when we define undefined keycodes.
Comment 3 Steven Michaud [:smichaud] (Retired) 2012-07-03 12:18:40 PDT
Comment on attachment 632591 [details] [diff] [review]
part.1 Use virtual keycodes defined in SDK

Where do symbols like "kVK_F16" live?  I can't find them anywhere in the tree.

What is the "SDK"?  It seems to be a separate download.  Which means that these patches will make it an additional build prerequisite.
Comment 4 Steven Michaud [:smichaud] (Retired) 2012-07-03 12:23:13 PDT
> Where do symbols like "kVK_F16" live?  I can't find them anywhere in the tree.

Never mind.  I just found them in the Events.h header file of Apple's HIToolbox framework.
Comment 5 Steven Michaud [:smichaud] (Retired) 2012-07-03 14:40:17 PDT
Comment on attachment 632591 [details] [diff] [review]
part.1 Use virtual keycodes defined in SDK

This looks fine to me.

I notice that you've dropped the "tilde" keycode (0x32).  But that's just because Events.h calls it by a different name (kVK_ANSI_Grave).

I did a build (on OS X 10.7.4) of both this bug's patches, and it finished with no problems.
Comment 6 Steven Michaud [:smichaud] (Retired) 2012-07-03 14:40:52 PDT
Comment on attachment 632592 [details] [diff] [review]
part.2 Use naming rules of virtual keycodes in SDK for defining undefined keycode

Looks fine to me.

I did a build (on OS X 10.7.4) of both this bug's patches, and it finished with no problems.

Note You need to log in before you can comment on or make changes to this bug.