src is not a vaild attribute on the search button

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: icaaq, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:16.0) Gecko/16.0 Firefox/16.0a1
Build ID: 20120609030536

Steps to reproduce:

1. Press Cmd+N to open a new browser window, then type https://addons.mozilla.org/en-US/firefox/ in the address bar and press Enter
2. Inspect the #search > button.search-button


Actual results:

A src-attribute is present.

src='https://static-ssl-cdn.addons.mozilla.net/media/img/zamboni/global/btn-search.png?b=3687a20'


Expected results:

The src attribute is not a valid attribute on the button element, it is safe to and it should be removed.

http://dev.w3.org/html5/spec/single-page.html#the-button-element
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
I assume this was added as a fix for an old IE issue or something.  Is this a problem for anything other than validating properly?
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.