Ice Cream Sandwich integration regression in the appearance of the application menu

RESOLVED DUPLICATE of bug 769237

Status

()

RESOLVED DUPLICATE of bug 769237
7 years ago
7 years ago

People

(Reporter: hsivonen, Unassigned)

Tracking

({regression})

Trunk
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Steps to reproduce:
1) Install Nightly on Galaxy Nexus.
2) Invoke the application menu.

Actual results:
The toolbar item for invoking the application menu is an icon with three horizontal lines on top of each other. It resembles the application menu icon on Honeycomb but doesn't match its appearance exactly. The menu that shows up looks neither like a Honeycomb menu nor like an Ice Cream Sandwich menu.

Expected results:
Expected the previous behavior of the Nightly on Ice Cream Sandwich. That is, expected the application menu button to be at the top right corner of the area of the screen available to the application, expected the application menu button to be a black area with three grey square dots on top of each other. Expected the menu that opens to have a rectangular shape without a speech bubble-like wedge pointing to the menu button and expected the background color of the menu to be dark gray. Expected the font size in the menu to match the font size in the menus shown by the apps bundled with the phone. Expected menu items to have text only without icons.
(Reporter)

Updated

7 years ago
Keywords: regression
Hi Henri, we recently made a UX call to move back to a more standard menu button placement for ICS phones. You can follow that work in bug 769237

The custom menu styling, however, is moving forward, as part of our efforts to build an app that respects Android interaction conventions but *also* builds on them in useful and interesting ways. You can follow some of these enhancements in bug 768083

Given work that is happening on other bugs, I am resolving this as a dupe.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769237
(Reporter)

Comment 2

7 years ago
(In reply to Ian Barlow (:ibarlow) from comment #1)
> The custom menu styling, however, is moving forward, as part of our efforts
> to build an app that respects Android interaction conventions but *also*
> builds on them in useful and interesting ways. You can follow some of these
> enhancements in bug 768083
> 
> Given work that is happening on other bugs, I am resolving this as a dupe.

AFAICT, what you are doing is really WONTFIXing this, since this isn't really a duplicate of the other bug when the other bug that doesn't involving restoring the native appearance.

I disagree with making the menu button look non-native.

We wouldn't make a departure of that magnitude of the platform look on Mac. Why does UX consider it OK to deviate from the ICS/JB holographic look more than what would be acceptable deviation from the platform look on Mac OS X?
There's already a pattern of overriding the menu in Google's own apps (i.e. Chrome and Maps do). I'd say this is more similar to something like tabs in the titlebar on Mac (which we are going to do). Custom behaviour to enhance the usability/experience, but not something so different that users can't quickly adjust.
You need to log in before you can comment on or make changes to this bug.