The default bug view has changed. See this FAQ.

[PAC][SPDY] Proxy setting for HTTPS proxy not considered

RESOLVED DUPLICATE of bug 378637

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 378637
5 years ago
5 years ago

People

(Reporter: knocke.julian, Unassigned)

Tracking

15 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0 Iceweasel/13.0
Build ID: 20120605094937

Steps to reproduce:

Change proxy settings to a simple PAC: file:///var/www/pac.js
function FindProxyForURL(url, host)
   {
        return "HTTPS localhost:8443";
   }

Started a SPDY proxy on localhost:8443 and opened http://www.wikipedia.org.


Actual results:

Used direct connection without proxy.


Expected results:

Regarding to http://dev.chromium.org/spdy/spdy-proxy the browser should use the proxy with SPDY to get that url.

Comment 1

5 years ago
That's not the correct syntax (currently) for a PAC file. FindProxyForURL should return a string starting with PROXY, DIRECT, or SOCKS (on windows). Switching from http to https doesn't work like that.

http://dev.chromium.org/spdy/spdy-proxy even mentions that they're planning to change the syntax. So why do you file a bug ? Do you want the same code change ?
(Reporter)

Comment 2

5 years ago
Yep. Honestly I did not know any better place to post this request. It already works on Chrome like this, so i filed a bug.

Comment 3

5 years ago
Then you should have searched Bugzilla a bit better : bug 378637 mentions the same change, and it's not SPDY related.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 378637
You need to log in before you can comment on or make changes to this bug.