crash [@ TouchBadMemory | mozalloc_abort | js::ctypes::ArrayType::AddressOfElement ]

RESOLVED DUPLICATE of bug 746730

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 746730
6 years ago
6 years ago

People

(Reporter: xti, Unassigned)

Tracking

({crash, reproducible})

14 Branch
ARM
Android
crash, reproducible
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-1f190904-c2ed-4f63-9c04-8943c2120613 .
============================================================= 

Frame 	Module 	Signature 	Source
0 	libmozalloc.so 	TouchBadMemory 	memory/mozalloc/mozalloc_abort.cpp:68
1 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:89
2 	dalvik-heap (deleted) 	dalvik-heap @0x7aa11f 	
3 	dalvik-mark-stack (deleted) 	dalvik-mark-stack @0x31a8f40 	
4 	libxul.so 	js::ctypes::ArrayType::AddressOfElement 	js/src/jsapi.h:925
5 		@0x68746467 	
6 	libxul.so 	anp_unref 	gfx/skia/include/core/SkRefCnt.h:59
7 		@0x72646e5f 	
8 	dalvik-heap (deleted) 	dalvik-heap @0xccce577 	
9 	dalvik-heap (deleted) 	dalvik-heap @0x6a9f263 	
10 	libxul.so 	nsACString_internal::AppendFunc 	nsTSubstring.h:388
11 	libnspr4.so 	FuncStuff 	nsprpub/pr/src/io/prprf.c:1075
12 	libnspr4.so 	fill_n 	nsprpub/pr/src/io/prprf.c:237
13 		@0x64 	
14 	libxul.so 	nsACString_internal::ReplaceASCII 	xpcom/string/src/nsTSubstring.cpp:503
15 	libxul.so 	nsACString_internal::AppendFunc 	nsTSubstring.h:388
16 	libnspr4.so 	FuncStuff 	nsprpub/pr/src/io/prprf.c:1075
17 	libnspr4.so 	dosprintf 	nsprpub/pr/src/io/prprf.c:1060
18 	libnspr4.so 	PR_vsxprintf 	nsprpub/pr/src/io/prprf.c:1105
19 		@0x62cdba5e 	
20 	app_process 	app_process@0xcd4 	
21 	libxul.so 	mozilla::layers::LayerManagerOGL::CreateFBOWithTexture 	gfx/layers/opengl/LayerManagerOGL.cpp:1251
22 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:215
23 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:252
24 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:252
25 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:252
26 	libxul.so 	mozilla::layers::LayerManagerOGL::Render 	gfx/layers/opengl/LayerManagerOGL.cpp:833
27 	libxul.so 	mozilla::layers::LayerManagerOGL::EndTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:468
28 	libxul.so 	mozilla::layers::LayerManagerOGL::EndEmptyTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:441
29 	libxul.so 	mozilla::layers::CompositorParent::Composite 	gfx/layers/ipc/CompositorParent.cpp:259
30 	libxul.so 	RunnableMethod<mozilla::layers::CompositorParent, void , Tuple0>::Run 	ipc/chromium/src/base/tuple.h:383
31 	libxul.so 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:318
32 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:326
33 	libxul.so 	MessageLoop::DoDelayedWork 	ipc/chromium/src/base/message_loop.cc:453
34 	libxul.so 	base::MessagePumpDefault::Run 	ipc/chromium/src/base/message_pump_default.cc:27
35 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
36 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
37 	libxul.so 	base::Thread::ThreadMain 	ipc/chromium/src/base/thread.cc:156
38 	libxul.so 	ThreadFunc 	ipc/chromium/src/base/platform_thread_posix.cc:26
39 	libc.so 	libc.so@0x12c1e 	
40 	libc.so 	libc.so@0x12772


Note: There are the same STR as in Bug 764392

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 746730
You need to log in before you can comment on or make changes to this bug.