[traceback] Error: UnicodeEncodeError: 'ascii' codec can't encode character u'\xe1' in position 63: ordinal not in range(128)

VERIFIED DUPLICATE of bug 748057

Status

Participation Infrastructure
Phonebook
VERIFIED DUPLICATE of bug 748057
6 years ago
6 years ago

People

(Reporter: mbrandt, Unassigned)

Tracking

Details

(Whiteboard: [prod][traceback], URL)

(Reporter)

Description

6 years ago
[mozillians] ERROR (EXTERNAL IP): Internal Server Error: /hu/user/edit

POST:<QueryDict: {u'website': [u''], u'bio': [u'vir\xe1gokat']


Traceback (most recent call last):

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/views/decorators/cache.py", line 88, in _wrapped_view_func
   response = view_func(request, *args, **kwargs)

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/contrib/auth/decorators.py", line 19, in _wrapped_view
   return view_func(request, *args, **kwargs)

 File "/data/www/mozillians.org/mozillians/apps/phonebook/views.py", line 71, in edit_profile
   form.save(request)

 File "/data/www/mozillians.org/mozillians/apps/phonebook/forms.py", line 173, in save
   super(ProfileForm, self).save(request.user)

 File "/data/www/mozillians.org/mozillians/apps/phonebook/forms.py", line 99, in save
   super(forms.ModelForm, self).save()

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/forms/models.py", line 363, in save
   fail_message, commit, construct=False)

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/forms/models.py", line 85, in save_instance
   instance.save()

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/db/models/base.py", line 463, in save
   self.save_base(using=using, force_insert=force_insert, force_update=force_update)

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/db/models/base.py", line 528, in save_base
   values = [(f, None, (raw and getattr(self, f.attname) or f.pre_save(self, False))) for f in non_pks]

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/db/models/fields/files.py", line 253, in pre_save
   file.save(file.name, file, save=False)

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/db/models/fields/files.py", line 90, in save
   self.name = self.storage.save(name, content)

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/core/files/storage.py", line 48, in save
   name = self.get_available_name(name)

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/core/files/storage.py", line 74, in get_available_name
   while self.exists(name):

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/core/files/storage.py", line 233, in exists
   return os.path.exists(self.path(name))

 File "/usr/lib64/python2.6/genericpath.py", line 18, in exists
   st = os.stat(path)

UnicodeEncodeError: 'ascii' codec can't encode character u'\xe1' in position 63: ordinal not in range(128)
Another duplicate of the uploading an image with a non-ascii filename bug.

We really need Sentry to aggregate these for us. Traceback is the same.
(Reporter)

Comment 2

6 years ago
Thanks James - marking duplicate of non-ascii filename boog
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 748057
(Reporter)

Updated

6 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.