JavaScript error when Adding Language in Preferences

VERIFIED FIXED in mozilla0.9.4

Status

VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: cplyon, Assigned: jbetak)

Tracking

Trunk
mozilla0.9.4
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: have fix, need sr)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Using build 2001041704 on Win2K

Steps to Reproduce:
1. Open the prefs dialog
2. Go to Navigator->Languages
3. Push the Add... button

Results:
The correct dialog opens, but with this error:
Error: document.getElementById("remove") has no properties
Source File: chrome://communicator/content/pref/pref-languages.js
Line: 593
This error does not prevent the language from being added.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

18 years ago
*** Bug 77681 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
*** Bug 82876 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
I don't see this warning to stdout, linux or w2k. -> WFM
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 4

18 years ago
But I saw the error in "Task -> Tools -> JavaScript Console".
Is there any misunderstanding here?

Bug still alive on Win32 build 2001053104.
(Reporter)

Comment 5

18 years ago
I'm still seeing this error appear in the JavaScript Console as well.
Using build 2001053104 om Win2K.

Comment 6

18 years ago
oops you're right, I was looking at stdout, yes I see this in JS console.
reopening
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 7

18 years ago
matt
Assignee: mcafee → matt
Status: REOPENED → NEW
(Reporter)

Comment 8

18 years ago
*** Bug 77047 has been marked as a duplicate of this bug. ***
*** Bug 84118 has been marked as a duplicate of this bug. ***
matt: I'm taking this, could be a problem in my code in language prefs...
Assignee: matt → jbetak
Created attachment 42142 [details] [diff] [review]
trunk patch - SelectLanguage() should only be called by the main pref panel
matt:

could you please review this? SelectLanguage() was called by the popup window, 
which caused this JS error. I also revised the opendialog parameters to address 
some nasty flickering...

Thanks!
Status: NEW → ASSIGNED
OS: Windows 2000 → All
Target Milestone: --- → mozilla0.9.3
Whiteboard: have fix, need r/sr
adding jag for r, since he has worked with pref-languages.js, cc'ing blake and 
ben for possible sr.
pushing out to 0.9.4
Target Milestone: mozilla0.9.3 → mozilla0.9.4
r=jag
thanks jag!
Whiteboard: have fix, need r/sr → have fix, need sr
cc'ing shaver for JS sr...
Chris: could you sr this one as well? It's a one-liner...
sr=blizzard
patch checked in - thanks everyone!
resolving...
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
vrfy fixed; no longer see the js error when clicking the Add button.

linux, 2001.08.22.08-comm
winnt, 2001.08.22.09-comm
mac 9.1, 2001.08.22.08-comm
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.