After cancelling replacement installation, `Go Back' button should remain disabled

VERIFIED FIXED in mozilla0.9.1


17 years ago
14 years ago


(Reporter: Matthew Paul Thomas, Assigned: Samir Gehani)


Mac System 9.x

Firefox Tracking Flags

(Not tracked)


(Whiteboard: Fix in hand (reviewed and super reviewed))


(1 attachment)



17 years ago
Build: 2001041704, Mac OS 9.1

To reproduce:
*   Install Mozilla.
*   Start re-installing Mozilla, and specify the same folder to install it in.
*   Click `Continue'.
*   In the alert which appears, click `Cancel'.
*   Click `Go Back'.

What should happen:
*   You return to the license screen.

What actually happens:
*   You don't go back to the license screen.
*   The button doesn't even appear recessed when you click it.


17 years ago
QA Contact: gemal → gbush

Comment 1

17 years ago
Ack!  The "Go Back" button should remain disabled to be consistent with the
behavior of the "setup type" dialog before the nuke from orbit alert is displayed.  
Summary: After cancelling replacement installation, `Go Back' button is unresponsive → After cancelling replacement installation, `Go Back' button should remain disabled

Comment 2

17 years ago
Why shouldn't you be able to go back to the license screen? That might be a 
separate bug blocking this one ...

Comment 3

17 years ago
I am mimicking our 4.x installers and other Mac products' installers including 
Quicktime by not allowing the user to return to the license screen once they 
have clicked the "Accept" button.  They still have the option to cancel the 
install at a later stage.  I was under the impression that there was a legal 
underpinning to not allow users to return to teh license screen once they have 
accepted the license terms.  Please deny or confirm.  Thanks for your time.

Comment 4

17 years ago
Is there a legal reason not to allow users to return the license screen once 
they've accepted the license? Hmm, interesting question. Note that I am not a 
lawyer, and this is not legal advice. If you want a legal opinion you should ask 
one of the Netscape lawyers why the 4.x installer was set up that way.

But just for fun I'll "think out loud" for a moment... If you did let users go 
back to the license screen then the following things could happen (I'll 
apologize in advance for not actually looking at the real UI, but just 
theorizing based on my idea of it):

1) They could decide to select the option not to accept the license (assuming 
that's allowed by the UI). The installer would presumably then exit, just as it 
would if they had chosen not to accept the license originally.

2) They could decide to again select the option to accept the license (if that's 
allowed by the UI). The installer would presumably then continue to the next 
screen of the installation, just as it would have before.

3) They could cancel the install (if that's allowed by the UI). The installer 
would presumably then exit, just as it would if this option were selected on any 
other screen.

4) They could select the option to proceed to the next screen (if that's allowed 
by the UI). The installer would presumably then proceed to the next screen, just 
as it would if this option were selected on any other screen.

Cases 2, 3, and 4 seem unproblematic. However I can see where case 1 might be a 
problem, because it creates an ambiguity as to whether the user has actually 
accepted the license or not. (Yes, the user did click "I accept" the first time, 
but "I swear I didn't click that the first time, the program just went to the 
next screen on its own. I really meant not to accept the license and that's what 
I clicked on when I had the opportunity to do so." Yes, this is a bogus 
defense but lawyers are paid to reduce risk where possible, and that means 
trying to minimize the opportunity for someone to make a bogus defense.)

This ambiguity wouldn't necessarily matter, but it's possible that in the 
meantime (before the user going back and deciding not to accept the license) the 
installer may have downloaded software off the net in preparation for installing 
it. So now the ambiguity is whether the user is bound by the license terms for 
that software or not. Sure, if the user went back and decided not to accept the 
license then the installer could delete the downloaded software prior to 
exiting. However if there is a legal problem then that doesn't necessarily help 
it, because the user could have copied the software to another place, or the 
installer could crash on exit, leaving the software on the hard drive, or 

If I personally were implementing an installer like this then I would want to 
reduce ambiguity about license acceptance as much as practically possible. So in 
that case I would do one of two things: a) I would prohibit users from returning 
 to the license screen at all once they've accepted the license and gone past 
it, _or_ b) if I did let users return to the license screen, I would disable the 
options to accept or not accept the license, and just enable the "next" button. 
Of those two options I would probably prefer (a) (not permitting return to the 
license screen), eliminating the possibility that a user could claim that "Yeah, 
I did see the license screen, but it wouldn't let me not accept it, all I could 
do was press the 'next' button."

This may not correspond to a common sense idea of "how it should work", but, 
again, there is not necessarily any relationship between what "common sense" 
would dictate and what a lawyer might advise you to do. (Trust me, I've 
been through this.) Again, if you're concerned about this ask a lawyer at 

And why, some might ask, does care about what the lawyers at 
Netscape think? Why can't Mozilla just "do the right thing" regardless? Because 
IMO has an obligation not to cause problems for downstream 
distributors other than Netscape. If we have reason to believe that there might 
be a legal issue here -- and I believe we do -- then I would much rather follow 
the example already set by the 4.x installer, which presumably received review 
by Netscape legal staff, than do something different which has not received 
independent legal review and is not likely to (unless someone wants to donate 
money for legal fees).

So, not to repeat myself too much, but please don't change the current behavior 
without speaking to someone who is more qualified to render an opinion than 
myself. Mitchell Baker can probably refer you to someone appropriate. (Mitchell 
herself can't give you a formal response because she's no longer practicing law 
for Netscape -- or for anyone else for that matter.)

Comment 5

17 years ago
As always, thank you very much for the detailed response.  It is now much
clearer why we should stick with the current behavior.  

If you oppose this behavior and feel we should change it, please direct me, or
better yet direct this query and cc me, to appropriate legal counsel.  Else,
please indicate agreement with current behavior.  Thanks.  

Comment 6

17 years ago
Created attachment 32507 [details] [diff] [review]
Ensure back button remains disabled when the app is brought back to the front (z-order index restored to 0).

Comment 7

17 years ago
ssu, please r.
alecf, please sr.


Comment 8

17 years ago

Comment 9

17 years ago
> This may not correspond to a common sense idea of "how it should work" ...

No problem, filed bug 78026 for that.

Comment 10

17 years ago
wow, huge discussion on a minor issue. :)
sr=alecf, though the tabs look messed up - though maybe that's how they are
supposed to be... in any case, just make sure they are right before checking in,
no need to attach another patch


17 years ago
Whiteboard: Fix in hand (reviewed and super reviewed)


17 years ago
Target Milestone: --- → mozilla0.9.1

Comment 11

17 years ago
Fix checked in.
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
moz build 2001052504
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.