Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Web Console and Debugger stay checked in Web Developer menu after closing them with the close X button

RESOLVED FIXED in Firefox 15

Status

()

Firefox
Developer Tools
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Loic, Assigned: paul)

Tracking

({regression})

15 Branch
Firefox 16
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox15 verified)

Details

Attachments

(1 attachment, 4 obsolete attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1
Build ID: 20120613030535

Steps to reproduce:

1) Open both Web Console and Debugger
2) Close both Web Console and Debugger with the close X button
3) Go to the Web Developer menu


Actual results:

Web Console and Debugger stay checked in the Web Developer menu (check mark still visible).
(Reporter)

Updated

5 years ago
Component: Untriaged → Menus
(Reporter)

Updated

5 years ago
Keywords: regression, regressionwindow-wanted

Comment 1

5 years ago
I see the same behavior on Windows XP and Ubuntu.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
(Reporter)

Comment 2

5 years ago
Mozregression range:

m-c:
good: 2012-05-11
bad: 2012-05-12
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e6a9572b48f7&tochange=22a58090fa70

m-i:
good: 2012-05-13
bad: 2012-05-14
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=3e0f7b9a39d7&tochange=3eab6ea25342

I'd say the culprit is:
Paul Rouget — Bug 749626 - Theme update: make the close button code generic and implement the dark theme for menulists. r=dao
OS: All → Windows 7
(Reporter)

Updated

5 years ago
Blocks: 749626
Component: Menus → Developer Tools
Keywords: regressionwindow-wanted
(Reporter)

Updated

5 years ago
OS: Windows 7 → All
Hardware: x86_64 → All

Comment 3

5 years ago
Last Good:f80568dba010
First Bad:2e5b9ba8358b

Triggered by:2e5b9ba8358b	Joe Walker — Bug 720641 - Integrate GCLI into developer tools global toolbar; r=dcamp,dão,robcee,zpao
Blocks: 720641
No longer blocks: 749626
tracking-firefox15: --- → ?
Version: 16 Branch → 15 Branch
(Assignee)

Comment 4

5 years ago
Known for the Web Console: bug 759384
And I'm pretty sure we also have a bug for the debugger.
(In reply to Paul Rouget [:paul] from comment #4)
> Known for the Web Console: bug 759384
> And I'm pretty sure we also have a bug for the debugger.

Bug 760771.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 760771
(Assignee)

Updated

5 years ago
Duplicate of this bug: 759384
(Assignee)

Updated

5 years ago
Assignee: nobody → paul
(Assignee)

Comment 8

5 years ago
For the web console, we should use setAttribute(checked, false) on the command (not remove attribute). We want the attribute value to propagate.

For the debugger, we will have the same problem. But we don't even update the value on tab change. I'll look at this today.
(Assignee)

Comment 9

5 years ago
Created attachment 633517 [details] [diff] [review]
v1
(Assignee)

Comment 10

5 years ago
This only works if the toolbar is active. It needs more work.
(Assignee)

Comment 11

5 years ago
Created attachment 633557 [details] [diff] [review]
v2
(Assignee)

Updated

5 years ago
Attachment #633517 - Attachment is obsolete: true
(Assignee)

Comment 12

5 years ago
Comment on attachment 633557 [details] [diff] [review]
v2

Can you guys take a look at this patch and tell me if there's a better play to register these listeners (debugger & webconsole)?

Thanks.
Attachment #633557 - Flags: feedback?(past)
Attachment #633557 - Flags: feedback?(mihai.sucan)
(Assignee)

Comment 13

5 years ago
Comment on attachment 633557 [details] [diff] [review]
v2

Little mistake in the patch, re-uploading soon.
Attachment #633557 - Flags: feedback?(past)
Attachment #633557 - Flags: feedback?(mihai.sucan)
(Assignee)

Comment 14

5 years ago
Created attachment 633567 [details] [diff] [review]
v2.1
(Assignee)

Updated

5 years ago
Attachment #633557 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
Attachment #633567 - Flags: feedback?(past)
Attachment #633567 - Flags: feedback?(mihai.sucan)
Comment on attachment 633567 [details] [diff] [review]
v2.1

Paul: this looks good to me, but I'd like a small change such that it fits with the existing onWindowUnload. Also please add the TabSelect event listener alongside the existing TabClose event listener.

What happens when the second window is open? Are the event listeners added for the second window as well?

Thanks!
Attachment #633567 - Flags: feedback?(mihai.sucan) → feedback+
Comment on attachment 633567 [details] [diff] [review]
v2.1

Review of attachment 633567 [details] [diff] [review]:
-----------------------------------------------------------------

Looks OK, DebuggerUI is the right place to handle global listeners. Have you verified it works OK when multiple windows are open (with multiple tabs)?
Attachment #633567 - Flags: feedback?(past) → feedback+
(Assignee)

Updated

5 years ago
Blocks: 763932
(Assignee)

Comment 17

5 years ago
(In reply to Panos Astithas [:past] from comment #16)
> Looks OK, DebuggerUI is the right place to handle global listeners. Have you
> verified it works OK when multiple windows are open (with multiple tabs)?

I did.
(Assignee)

Comment 18

5 years ago
Created attachment 633752 [details] [diff] [review]
v2.2

Addressed Mihai's comments. Added tests.
(Assignee)

Updated

5 years ago
Attachment #633567 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
Attachment #633752 - Flags: review?(past)
Attachment #633752 - Flags: review?(mihai.sucan)
Comment on attachment 633752 [details] [diff] [review]
v2.2

Looks good to me. Thanks for the update.
Attachment #633752 - Flags: review?(mihai.sucan) → review+
Comment on attachment 633752 [details] [diff] [review]
v2.2

Review of attachment 633752 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/debugger/test/browser_dbg_menustatus.js
@@ +3,5 @@
> + * Any copyright is dedicated to the Public Domain.
> + * http://creativecommons.org/publicdomain/zero/1.0/
> + */
> +
> +function test() {

Nit: could you add a one-line comment above that explains the purpose of the test?

@@ +28,5 @@
> +        is(cmd.getAttribute("checked"), "true", "<command Tools:Debugger> is checked.");
> +
> +        let pane = DebuggerUI.toggleDebugger();
> +
> +        is(cmd.getAttribute("checked"), "false", "<command Tools:Debugger> is checked once closed.");

s/checked/unchecked/
Attachment #633752 - Flags: review?(past) → review+
Duplicate of this bug: 760839
(Assignee)

Comment 22

5 years ago
Created attachment 634478 [details] [diff] [review]
v2.2 - to land
(Assignee)

Updated

5 years ago
Attachment #633752 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
Whiteboard: [land-in-fx-team]

Comment 23

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/f50196512e83
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]

Updated

5 years ago
tracking-firefox15: ? → +
https://hg.mozilla.org/mozilla-central/rev/f50196512e83
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 16
Comment on attachment 634478 [details] [diff] [review]
v2.2 - to land

[Approval Request Comment]
Bug caused by (feature/regressing bug #): The debugger is a new feature, but the console seems to have regressed with bug 749626
User impact if declined: inconsistent state of the web console and debugger check marks in the menu
Testing completed (on m-c, etc.): On m-c and fx-team
Risk to taking this patch (and alternatives if risky): fairly minimal patch, in two predominantly developer-only features
String or UUID changes made by this patch: none
Attachment #634478 - Flags: approval-mozilla-aurora?
Comment on attachment 634478 [details] [diff] [review]
v2.2 - to land

[Triage Comment]
Very limited scope, and we've got QA/engineer/external testing specifically around the new dev tools changes. I expect we'll find any regressions quickly.
Attachment #634478 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/e75777b217ea
status-firefox15: --- → fixed
tracking-firefox15: + → ---

Comment 28

5 years ago
Verified as fixed on:
Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0
status-firefox15: fixed → verified
You need to log in before you can comment on or make changes to this bug.