getfirefox.com doesn't work in fresh patched WinXP install

RESOLVED WORKSFORME

Status

Webtools
Bouncer
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: cpearce, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
In installed WinXP SP3 in a VirtualBox VM, updated it fully with Windows Update, and now am trying to download Firefox from getfirefox.com (which redirects to m.o/en-US/products/download.html?...). This is using Internet Explorer 8.

But the download never begins on the download.html page, and the if I click on the "If not, click here" text/link, I'm navigated back to the page getfirefox.com redirects to, so it's not much use. It's impossible to download Release Channel Firefox in my WinXP VM. I'm not sure if this happens when WinXP is installed on a physical machine.

I tried it in Internet Explorer 9 on my Win7 machine and had to wait almost a minute before the download prompt happened. Not a good look, how many downloads are we losing because people are giving up waiting?

Comment 1

6 years ago
Alex, can you help get this verified and find some next steps?

Comment 2

6 years ago
(In reply to JP Rosevear [:jpr] from comment #1)
> Alex, can you help get this verified and find some next steps?

This is a website issue, but I honestly don't know the right way to get eyes on.

morgamic - sorry for sending this your way, but it was the best path forward I could think of :)
Assignee: nobody → morgamic
(Reporter)

Comment 3

6 years ago
I'm in Toronto this week, and tested it again. GetFirefox.com works fine in IE7 in Tornoto, so it's probably a network issue.

The initial problem I had occurred when I was in New Zealand. If there's something I can do to help diagnose this (like a provide traceroute or something) just let me know.
This might be a bouncer issue. This is the software that chooses which mirror will serve you the download. Maybe one of the mirrors was behaving badly at that time. Can someone test from New Zealand in IE7/8 to check if this is still happening?

Chris: Have you tried several times?

Not that calling download.mozilla.org without arguments redirect to www.mozilla.com. So it might just be that instead of a bad behaving mirror.
Assignee: morgamic → nobody
Component: www.mozilla.org → Bouncer
Product: Websites → Webtools
Version: unspecified → Trunk
On the webside, getfirefox.com's download box is (currently) a link to
 http://www.mozilla.org/products/download.html?product=firefox-14.0.1&os=osx&lang=en-US
which is a sort-of interstitial that makes a request to
 http://download.mozilla.org/?product=firefox-14.0.1&os=win&lang=en-US
in the background. That should lead to a dialog to save the file. Are there any messages in the Error Console ? The URL is a concatenation in JS when that's enabled; hardwired otherwise.

Re maybe mirror failure, the situation today is a bit different from back in June, so to try and reproduce this you'd need to make a request like this
http://download.mozilla.org/?product=firefox-14.0.1-funnelcake13&os=win&lang=en-US

download.m.o (aka Bouncer) then has an Australia region (which includes NZ, always the little brother eh mate) which will send requests to one of these mirrors 
 Likelihood   Mirror
   60%        http://mozilla.mirror.aarnet.edu.au
   21%        http://mirror.xnet.co.nz
   13%        http://mozilla.mirror.uber.com.au
    5%        http://mirror.internode.on.net
    1%        http://mirror.waia.asn.au
  0.1%        http://download.cdn.mozilla.net
That's as of today, it would have been a bit different mid-June; the last one is a meta-CDN, you can end up on Akamai or another couple of big CDNs.

If the issue is still reproducible in Firefox then you can try requests like
  wget -S -O foo "http://download.mozilla.org/?product=firefox-14.0.1-funnelcake13&os=win&lang=en-US"
to identify the mirror, or to see if you get sent elsewhere.
Oh, and I can't reproduce the problem with an XP VM with IE8.
(Reporter)

Comment 7

6 years ago
(In reply to Nick Thomas [:nthomas] from comment #6)
> Oh, and I can't reproduce the problem with an XP VM with IE8.

I can no longer reproduce this in IE8 (in NZ), with either getfirefox.com as it stands today, or with the funnelcake link nthomas provides in comment 5.

I think we can WFM this, it's no longer reproducible.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.