URGENT - email sign up forms on /firefox/13.0/whatsnew/ are not configured properly

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: jdavis, Assigned: pascalc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Steps to reproduce error:

https://www.mozilla.org/pt-BR/firefox/13.0/whatsnew/#

Sign up for the newsletter - receive en-US welcome email (and in Exact target the LangISO2 = blank so the email recipient will get the EN newsletter).


Same error on these locales:
es-ES, de, fr

Es does not work at all - signup form does nothing with the email address.

Expected behavior:
All of these forms (es, es-ES, pt-BR, de, and fr) should work like the l10n forms on the footers of https://www.mozilla.org/firefox/fx/ 
(ie https://www.mozilla.org/de/firefox/fx/, https://www.mozilla.org/fr/firefox/fx/, etc. ) 

This needs to be fixed ASAP
It looks like Steven from Silver Orange created this page per the revision history here:

http://viewvc.svn.mozilla.org/vc/projects/mozilla.com/trunk/en-US/firefox/13.0/whatsnew/?pathrev=105336
Assignee: pascalc → anthony
Rik: Can you check this out asap Thursday AM? Talk to Steven since he created the page.
Here is the implementation bug and QA testing: https://bugzilla.mozilla.org/show_bug.cgi?id=752689
(Assignee)

Comment 4

7 years ago
I looked at the page and this is because unlike other places where we have a sign up form, there is no language select picker (= no default value for that field). Since I worked on the newsletter center, I know enough about this code to fix it this morning.
(Assignee)

Comment 5

7 years ago
Adding back the language select, we go from these values in $_POST for the page in Spanish:

mozilla-and-you=Y
email=pascal.chevrel%40free.fr
country=us
format=html
privacy=on
submit=Suscribirme%C2%A0%C2%BB#


To these values:

mozilla-and-you=Y
email=pascal.chevrel%40free.fr
lang=es-ES
country=es
format=html
privacy=on
submit=Suscribirme%C2%A0%C2%BB#


Which I believe are the correct values, I am going to push that to dev now.
(Assignee)

Comment 6

7 years ago
committed in r106345 for locales, I am leaving en-US aside since unlike locales it doesn't go through a template and I'd prefer Steven to look at it (especially since we have a 13.0.1 coming that may use this page)
(Assignee)

Comment 7

7 years ago
I tried with French and we now receive a welcome email in the right language, that welcome email contains a confirmation link but that confirmation link leads to a page saying "The supplied link has expired. You will receive a new one in the next newsletter. ".

I think the subscription will work for English since there is no confirmation page needed, I am going to just deactivate the newsletter subsription form for locales for now on this page until we can debug with Jessilyn together, no need to expose a broken feature to users. Jessilyn, would you be available this evening (your morning) to work with me on IRC on debugging the form on this page?
(Assignee)

Comment 8

7 years ago
newsletter form hidden by default on localized pages until we can Sync with Jess https://www.mozilla.org/fr/firefox/13.0/whatsnew
Assignee: anthony → pascalc
(Assignee)

Comment 9

7 years ago
I worked online with Jess and the bug was solved in r106364 (international pages need a double opt-in parameter set to feed the right database), we have tested on the dev site and now that the language select field was also added, we activated the form for all locales. All of our testing shows that things are now behaving as expected and we pushed to production in r106371

We are going to test a bit more on production in case a bug shows up that didn't happen on trunk, of everything goes well, we'll close the bug.
(Reporter)

Comment 10

7 years ago
Tested all newsletter locales + a few extra locales with this signup form. All looks great.

Thanks Pascal!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
I believe this is another example about why we need to get off of two different code bases for Mozilla.org asap. We are spending most of our efforts on the new Python/Django code/pages and we are setting ourselves up for more work and possible problems the longer we wait. The current site it is more work for devs, more work for QA, and a fragmented experience for our non-en-US visitors.

Most movement off of the PHP has been halted due to focus on everything that we are working on for the Fennec release for the 26th. I have some additional ideas that I'm discussing with the team.
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.