If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Web Console: focus doesn't return to the command line after an alert is displayed

RESOLVED WONTFIX

Status

()

Firefox
Developer Tools: Console
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: mjh563, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
After using the Web console to show an alert, the keyboard focus is not returned to the command line.

Steps to reproduce:

1. Open the Web console (Ctrl+Shift+K)
2. At the command line, type alert("x") and press Enter
3. Close the alert box that appears
4. Type some more text

Actual results:

Nothing happens, because the keyboard focus is no longer on the command line (it's put onto the web page instead).

Expected results:

The characters typed should have appeared on the Web console command line, because that's where I was typing before the alert was shown.
(Reporter)

Updated

5 years ago
Summary: Web console: focus doesn't return to the command line after an alert is displayed → Web Console: focus doesn't return to the command line after an alert is displayed
When using alert() the user is explicitly switching focus to content, so I think we shouldn't do anything differently here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.