[NativeUI GA] promo graphic for blog

RESOLVED FIXED

Status

Marketing
Design
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Tara (musingt), Assigned: Lee Tom)

Tracking

Details

Attachments

(5 attachments)

(Reporter)

Description

6 years ago
per my email, lets create a "backup" graphic in place of where the video was intended to be for the official press release post upon launch.

Assigning to Lee.

Would be nice to create two versions:
* One with some light copy, for en-US (good for message pull-through)
* One without for global audience
(Reporter)

Updated

6 years ago
Assignee: tshahian → ltom
Status: NEW → ASSIGNED
(Assignee)

Comment 1

6 years ago
Hi all, Just want to ping the bug to see what kind of content we're thinking of using here... I'm also wondering what the ideal specs or these deliverable will be. I'm assuming we would like to design around both print and web (high and low res.) Maybe start this based on the same specs as the Firefox in 2011 infographic?
(Reporter)

Comment 2

6 years ago
I'll let Jaclyn comment, but the infographic width would apply, not the length.  I think this is meant to be more of a hero graphic / banner of sorts vs. anything too big. Just some eye candy for the initial blog post announcing the release, and something that Press can pick up and share as they write about us.

Comment 3

6 years ago
+1 - we will want the screenshot of the Start Page in this one rather than the logo like the ones we've been using. Copy wise, just Firefox for Android will do
(Assignee)

Comment 4

6 years ago
Created attachment 634224 [details]
Firefox for Android blog graphic -01

"Firefox for Android"

- we may not need this localized?
(Reporter)

Comment 5

6 years ago
cool... is that our new lockup for Firefox for Android?
(Assignee)

Comment 6

6 years ago
Lockup is not official, no. Up to this point we've mostly been using:

"Fast. Smart. Safe."
and/or
"Get the mobile browser that's got your back."

please advise
(Reporter)

Comment 7

6 years ago
I don't think we've created an official lockup with the wordmarks like that (not as far as I know)  so I don't have a better alternative except to point to ways we've done it elsewhere...  or to use a different font so it doesn't look like an official lockup brand conflict.
(Reporter)

Comment 8

6 years ago
Created attachment 634227 [details]
this is what we did for MWC

Comment 9

6 years ago
Lee - can we blank out the device's buttons and the top status bar that has the time/battery life etc?
(Assignee)

Comment 10

6 years ago
Created attachment 634239 [details]
Firefox for Android blog graphic -02

Thanks for the reference img, Tara. How about this?

Comment 11

6 years ago
Great minds...I was just typing a comment suggesting italics. I like it, but would like to try scooting the italicized copy up a bit. Might feel tighter that way.

Also, is there a reason why we're not using the orange background/Fx logo treatment we're using on most of the phone images?

Comment 12

6 years ago
Also, how about Open Sans italics instead of Georgia?
(Assignee)

Comment 13

6 years ago
Created attachment 634601 [details]
Firefox for Android blog graphic -03

- removed phone buttons and battery life UI etc.
- Lock-up is now not really a lock-up, but a better lock-up than before.

Comment 14

6 years ago
I like it, thanks. Last question: is there a reason why we're not using the orange background/Fx logo treatment we're using on most of the phone images?
(Assignee)

Comment 15

6 years ago
Will let Jaclyn speak to this (Comment 3)

Comment 16

6 years ago
I don't have a preference on blue or orange

Comment 17

6 years ago
Sorry misread the comment, would like to use the actual screenshot since it's a press image and we can show off the new UI when press re-uses the image

thanks
(Assignee)

Comment 18

6 years ago
If there are no more changes here, you can grab the PNG in Comment 13 as final asset.

Comment 19

6 years ago
Jaclyn, have you checked with anyone on the PR team about this? I really like the image with the logo on it better...am wondering if it would be worth putting that one out as well as another one or two with screen shots included.

I'm not sure which a reporter would find more valuable, but I think it would be worth asking about.
(Assignee)

Comment 20

6 years ago
Created attachment 635120 [details]
Firefox for Android blog graphic -FFx

Attaching orange Firefox version here, to compare/use if you want to.

Comment 21

6 years ago
mark/erica - what do you think?
I like attachment 635120 [details] since we're going to include a screenshot of the Start Page in the blog post anyway

Comment 23

6 years ago
woot ok +1 thanks

Comment 24

6 years ago
I like that one too - thanks Lee.

Marking this as resolved - the file in comment #20 should work for the blog and related purposes.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.