If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

frames not reflected as frameset properties

CLOSED DUPLICATE of bug 1839

Status

()

Core
DOM: Core & HTML
P3
major
CLOSED DUPLICATE of bug 1839
19 years ago
19 years ago

People

(Reporter: martin.honnen, Assigned: vidur (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
With both existing ns and ms browsers the following doc
<HTML>
<HEAD>
</HEAD>
<FRAMESET ROWS="50%,  50%">
<FRAME NAME="frame0" SRC="nn5FrameReflection1.html">
<FRAME NAME="frame1" SRC="nn5FrameReflection1.html">
</FRAMESET>
</HTML>
causes the frames to be reflected as properties of the frameset window
  top.frameName
e.g
  top.frame0
  top.frame1
Mozilla m6 displays undefineds for the following
<HTML>
<HEAD>
<SCRIPT>
function testFrames() {
  for (var i = 0; i < frames.length; i++)
    alert(window[frames[i].name]);
}
</SCRIPT>
</HEAD>
<FRAMESET ROWS="50%,  50%" ONLOAD="testFrames()">
<FRAME NAME="frame0" SRC="nn5FrameReflection1.html">
<FRAME NAME="frame1" SRC="nn5FrameReflection1.html">
</FRAMESET>
</HTML>

That breaks a lot of DOM level 0 (which features list shows as 100% done) code I think.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

19 years ago
A known problem. Tom, you should probably move this higher up on your bug list
since it has so many DUPs.

*** This bug has been marked as a duplicate of 1839 ***

Updated

19 years ago
Status: RESOLVED → CLOSED

Comment 2

19 years ago
Closing this bug since dup of bug# 1839.
You need to log in before you can comment on or make changes to this bug.