Open target=blank links in <iframe mozapp> in the browser app

RESOLVED DUPLICATE of bug 769254

Status

RESOLVED DUPLICATE of bug 769254
6 years ago
6 years ago

People

(Reporter: justin.lebar+bug, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-kilimanjaro:?, blocking-basecamp:+)

Details

(Reporter)

Description

6 years ago
Cross-domain links in <iframe mozapp> should open in the browser app.  This is what we do for desktop webapps, bug 707836.

Presumably we need web intents before we can do this.

Also, I'm pretty sad we have to re-implement this sort of thing for b2g.
(Reporter)

Updated

6 years ago
Blocks: 693515
Can't we use the usual nsBrowserAccess mechanism?
All cross-domain links? Or can we have this behaviour for anchors specified with target="_blank"?
(Reporter)

Comment 3

6 years ago
(In reply to Chris Van Wiemeersch [:cvan] from comment #2)
> All cross-domain links? Or can we have this behaviour for anchors specified
> with target="_blank"?

All cross-domain links.  An app cannot move to another domain.

> Can't we use the usual nsBrowserAccess mechanism?

That's tagged off the browserDOMWindow?  Maybe...  We really should use intents here.
(In reply to Justin Lebar [:jlebar] from comment #3)
> (In reply to Chris Van Wiemeersch [:cvan] from comment #2)
> > All cross-domain links? Or can we have this behaviour for anchors specified
> > with target="_blank"?
> 
> All cross-domain links.  An app cannot move to another domain.

That's not consistent behavior with desktop, possibly with Android as well, although the Android piece is up to debate. We should strive for consistency here in this area especially, otherwise, we'll end up confusing developers to implement apps in different ways for different platforms (especially important that the Android piece = B2G piece). Why not follow the target blank specification in bug 752666 in desktop?

References:

* Desktop equivalent bug - bug 752666
* Android equivalent bug - bug 766802
(Reporter)

Comment 5

6 years ago
> All cross-domain links.  An app cannot move to another domain

Jonas tells me I misunderstood the implications of bug 752666.  We should match the behavior on desktop.

Updated

6 years ago
Summary: Open cross-domain links in <iframe mozapp> in the browser app → Open cross-domain target=blank links in <iframe mozapp> in the browser app

Updated

6 years ago
blocking-basecamp: --- → ?
blocking-kilimanjaro: --- → ?
On desktop we open all target=blank links in the browser, whether or not they are cross-domain.
Summary: Open cross-domain target=blank links in <iframe mozapp> in the browser app → Open target=blank links in <iframe mozapp> in the browser app
Blocks: 766199
No longer blocks: 752013
(Reporter)

Comment 7

6 years ago
This will be fixed on the Gecko side by bug 769254.  Gaia will still need to figure out its "open the browser" magic.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769254
+ing dupe
blocking-basecamp: ? → +
You need to log in before you can comment on or make changes to this bug.