RFE: New synchronize option: Keep (only) all read messages offline

RESOLVED DUPLICATE of bug 1302228

Status

--
enhancement
RESOLVED DUPLICATE of bug 1302228
6 years ago
9 months ago

People

(Reporter: hedayat.fwd+mz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gs], URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120605140154

Steps to reproduce:

I want to save bandwidth as much as possible. Therefore, I prefer to have my emails available offline. However, I don't want to have all my emails available offline, but whenever I read the message (and therefore, I've actually downloaded the message), I want it to be saved to disk so that I can read it again without downloading it again. Therefore, I suggest adding an option similar to "Keep all read messages" in Synchronization & Storage section of account settings. It can have a "maximum size" limit too, but that's not much important.


Actual results:

I have read a "big" message, and I'd like to have it offline. Currently, I can't do that without re-downloading the message (Using File->Offline->Get Selected Message results in re-downloading the message. Also, I'd prefer it to happen for all messages I read). 



Expected results:

Whenever I read a message, it's saved to disk so that I can access it offline.

Comment 1

6 years ago
(In reply to Hedayat Vatankhah from comment #0)
When you go offline, Thunderbird will ask you to "Do you want to download messages for offline use before going offline?". This will make them available without network connectivity.

Another option "which I didn't try yet" is that you apply a filter to copy your IMAP/POP messages when you download them to a local folder automatically. After that, you can see them available in the local folder.
(Reporter)

Comment 2

6 years ago
Nope. The first option downloads all email, rather than read emails. Also, it downloads the messages again. I want the emails which I read to be saved, and not to download them again later.
The other option is not what I want too. It's a workaround, and most probably needs re-downloads too. 
What I want is really simple for thunderbird to do: I want it to keep any message I read for offline use.
This sounds like a support issue. Did you ask on support.mozillamessaging.com ?
Component: General → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
(Reporter)

Comment 4

6 years ago
Sorry, how can it be a support issue? Doesn't look like to be supported by Thunderbird, snice there is nothing similar in its preferences.
(In reply to Hedayat Vatankhah from comment #4)
> Sorry, how can it be a support issue? Doesn't look like to be supported by
> Thunderbird, snice there is nothing similar in its preferences.

Cause with the proper options you can probably achieve what you want (ie like downloading only headers and then choosing to download complete messages).

Look at something like http://forums.mozillazine.org/viewtopic.php?f=28&t=688035&start=0&st=0&sk=t&sd=a
(Reporter)

Comment 6

6 years ago
OK, I asked it: https://getsatisfaction.com/mozilla_messaging/topics/is_it_possible_to_tell_thunderbird_to_keep_read_messages_for_offline_use

But I'm almost sure that Thunderbird doesn't provide this feature. There is another feature which is close to this one: to tell thunderbird to download only UNREAD messages (for IMAP). I saw this question being asked about 1 year ago without an answer, so I assume that Thunderbird doesn't provide that feature too.

Comment 7

6 years ago
If it can't already be done, these would serve such a narrow population of user I don't foresee anyone wanting to have code with this level of complexity in thunderbird imap support
Severity: normal → enhancement
(Reporter)

Comment 8

6 years ago
I just wonder how much complexity it has to store every read message permanently (instead of temporarily in the cache...).

Updated

6 years ago
Whiteboard: [gs]

Updated

2 years ago
OS: Linux → All
Summary: RFE: New synchronize option: Keep all message I read → RFE: New synchronize option: Keep (only) all read messages offline

Comment 9

9 months ago
bug 1302228 is a duplicate, but it has more detail. So duping to the newer bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1302228
You need to log in before you can comment on or make changes to this bug.