An email inside a tab is reloaded everytime the tab is selected

RESOLVED DUPLICATE of bug 487386

Status

Thunderbird
Message Reader UI
RESOLVED DUPLICATE of bug 487386
6 years ago
6 years ago

People

(Reporter: Hedayat Vatankhah, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120605140154

Steps to reproduce:

Opened an email in the main view. The I decide to view this email in a separate tab, so I right click on the message and select "Open message in a new tab". I select the tab to view the email, and then switched to the main view and selected another email. Later, I select the tab again to re-read the message.


Actual results:

When I open the message in the main view, it is loaded from the net. When I open it in a separate tab, it is loaded from the net again (?!). When I switch to the main view, the selected email in the main view is also re-loaded from the net. If I keep switching between the main view and the tab(s), (without doing anything else and without selecting a different email), the same emails are being re-downloaded again and again. This is clearly a waste of bandwidth and time, specially for larger messages.


Expected results:

The first email is loaded from the net when I read it in the main view. When I select "Open message in a new tab", it should not be reloaded from the net (since it is already loaded) and it should be instantly shown. Main view also should not reload an already loaded email.

Comment 1

6 years ago
(In reply to Hedayat Vatankhah from comment #0)
Open the message in a new tab then go offline, reloading will not happen after that.
(Reporter)

Comment 2

6 years ago
Thank you for the workaround. However, I think it needs a real fix.

However, even the workaround doesn't work either. I opened the message in a new tab, then went offline, then switched to the main view and switched again to the tab. This message appeared instead of the email:
"The body of this message has not been downloaded from the server for reading offline. To read this message, you must reconnect to the network, choose Offline from the File menu and then uncheck Work Offline. ...."
(Reporter)

Comment 3

6 years ago
I wonder if Thunderbird really uses "Disk cache" at all?!!!
(Reporter)

Comment 4

6 years ago
I wonder if Thunderbird really uses "Disk cache" at all?!!! It really doesn't cache anything!
(Reporter)

Comment 5

6 years ago
I checked now. The email is already in disk cache, but thunderbird doesn't use the cache!

Comment 6

6 years ago
It's a know problem, and yes - very annoying.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 487386
You need to log in before you can comment on or make changes to this bug.