Investigate whether call of OnDataAvailable may follow after OnStopRequest on listener of nsHttpChannel

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: mayhemer, Assigned: mayhemer)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

6 years ago
Reporting as unconfirmed just to raise attention of potential problem.  

This is one possible cause of bug 764758.

(in a nut shell: a class, that sets it self as a direct listener on nsHttpChannel, sets a member on it self after a successful call to AsyncOpen ; this member is deferenced in OnDataAvailable [occasional crash] and released in OnStopRequest)
(Assignee)

Comment 1

6 years ago
I've just got another stack, that shows this cannot happen according we always throw mListener away after call to OnStopRequest on it.  nsStreamListenerTee cannot be the cause, it's too simple class.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
I'm starting to wonder if we should install an initial listener class that does nothing but verify that we call OnStart/OnStop, and only call OnDataAvailible in between.
You need to log in before you can comment on or make changes to this bug.