Last Comment Bug 764923 - IonMonkey: Not inlining some functions due to OBJECT_FLAG_UNINLINEABLE
: IonMonkey: Not inlining some functions due to OBJECT_FLAG_UNINLINEABLE
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem]
:
Mentors:
Depends on:
Blocks: IonSpeed
  Show dependency treegraph
 
Reported: 2012-06-14 10:58 PDT by Jan de Mooij [:jandem]
Modified: 2012-06-16 13:37 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.93 KB, patch)
2012-06-15 03:40 PDT, Jan de Mooij [:jandem]
bhackett1024: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] 2012-06-14 10:58:52 PDT
JM+TI sets this flag to signal that a function shouldn't be inlined. Ion also checks this flag, but in many cases Ion can inline these functions just fine.

This prevents us from inlining some functions on Kraken imaging-darkroom - JM sets the flag there because it cannot generate native call stubs in inlined functions.
Comment 1 Jan de Mooij [:jandem] 2012-06-15 03:40:27 PDT
Created attachment 633466 [details] [diff] [review]
Patch

OBJECT_FLAG_UNINLINEABLE is set to either prevent us from expanding inlined frames over and over again or when JM wants to generate a native call/getter IC. With Ion we don't have to expand inline frames and we can generate ICs in inlined functions so I don't think we need to check this flag.
Comment 2 Jan de Mooij [:jandem] 2012-06-16 13:37:50 PDT
https://hg.mozilla.org/projects/ionmonkey/rev/a930dbb7ab60

Note You need to log in before you can comment on or make changes to this bug.