automate index file creation for final releases

RESOLVED DUPLICATE of bug 785965

Status

Release Engineering
Release Automation: Other
P3
normal
RESOLVED DUPLICATE of bug 785965
6 years ago
5 years ago

People

(Reporter: bhearsum, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Right now we do this by hand:
# ffxbld@stage
cd /pub/mozilla.org/firefox/releases/13.0
wget --no-check-certificate -O index.html https://bugzilla.mozilla.org/attachment.cgi?id=540139
sed -i -e 's/5/13/g' index.html 
for dir in `find . -mindepth 1 -type d `; do cp -pv index.html $dir/; done

Usually it ends up getting done after we copy into the releases/ directory; it would be good to have this done in candidates automatically, so that we're never in releases/ without index files.
Bug 761035 tweaked the html, please use what's there instead.
(Reporter)

Comment 2

6 years ago
This is getting done as part of bug 785965.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 785965
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.