If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add about: page event listeners only to pages that need them

RESOLVED DUPLICATE of bug 790934

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 790934
5 years ago
5 years ago

People

(Reporter: fryn, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 633254 [details] [diff] [review]
patch

We're currently adding the about: page event listeners to every about: page, including about:newtab and possibly about:blank. We should only add them to pages that need them.

We also add them twice for each document and each iframe inside those documents.
I have a patch that fixes the iframe piece.
Fixing the twice-per-document piece is more difficult. Marco and I were investigating that in bug 749477.
Attachment #633254 - Flags: review?(gavin.sharp)
(Reporter)

Updated

5 years ago
Attachment #633254 - Flags: review?(gavin.sharp)
(Reporter)

Comment 1

5 years ago
BrowserOnClick got refactored, which made the code easier to maintain and understand, but this bug still exists.

It doesn't seem to be a priority to address this, so unassigning self.
Status: ASSIGNED → NEW
(Reporter)

Updated

5 years ago
Assignee: fryn → nobody
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 790934
You need to log in before you can comment on or make changes to this bug.