google maps search fails when using https

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Marc Auslander, Unassigned)

Tracking

14 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0
Build ID: 20120605113340

Steps to reproduce:

maps.google.com - find a location - left click on the teardrop - click search nearby - enter a value - click search.




Actual results:

nothing

BUT - with an empty profile it works correctly.
With my profile with ALL plugins and add-ons disabled it does NOT work.
With my profile and Firefox 13 it does work.

If it's something in my profile I don't know where to start to find it.


Expected results:

search results displayed
(Reporter)

Comment 1

6 years ago
Also - typing hotel: location in the top search bar does work.
(Reporter)

Comment 2

6 years ago
Furthering the mystery.

I copied a clean prefs from a profile that "works" to the one that doesn't, and started in safe mode.  Still broken.
(Reporter)

Comment 3

6 years ago
I've pinned it down to places.sqlite

If I replace places with one from a working profile, the problem disappears.

If I sync a test working profile to my main, broken profile, it breaks the test profile.

If I export the bookmarks from the broken profile as html and import them into a good profile, it stays good.

I'll keep the broken places.sqlite, but its big.
(Reporter)

Comment 4

6 years ago
Sorry - its more complicated - i'll try to be quiet till I'm more sure.  It's an interaction of places and something else, I think.

I'm out of ideas.  I'm getting inconsistent results.  Clean places, remove all history, still broken.  safe-mode and it works.

But starting from scratch, safe-mode doesn't work.

It's some complex or intermittent mixture of things.  Sorry.

How can I help?
(Reporter)

Comment 5

6 years ago
I can "clear" the issue by:

1. remove all google.com cookies - maps still broken
2. backup my bookmarks
3. shutdown, replace places with one from an empty profile
4. at this point, maps works again
5. restore bookmarks from the json saved above - maps still works
(Reporter)

Comment 6

6 years ago
To reproduce:

1. create an empty profile and open firefox on it
2. go to maps.google.com
3. log in - I've tried my account and an old dummy account
4. find a location - I've been using princeton, nj
5. click on search nearby and enter a value - I've been using hotel
6. enter or click on search

nothing happens

Note that search before login works, search after logout does not.
(Reporter)

Comment 7

6 years ago
All the above are just mcguffins.

http://maps.google.com works
https://maps.google.com does not work
Summary: google maps search fails → google maps search fails when using https

Comment 8

6 years ago
I once had this and it was due to not allowing cookies in combination with the "HTTPS Everywhere" plugin.
Which add-ons/plugins do you use?
(Reporter)

Comment 9

6 years ago
1. This does NOT fail with Firefox 13.
2. I allow all cookies
3. I do no use the HTTPS everywhere plugin.
4. I don't know how to block cookies, and I haven't done so.  Cookies related functions work correctly.
(Reporter)

Comment 10

6 years ago
As of today this no longer happens.  Go figure.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.