Starting browser without mail&news

VERIFIED WORKSFORME

Status

--
enhancement
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: krogoth2, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
There should be an option to start the browser without loading mail&news in a 
full install. One of the reasons that I chose to use Internet Explorer instead 
of Netscape is that it takes a lot less time to load the browser. I see 
browsers and email applications as two seperate programs, and the mail&news 
shouldn't slow down the browser.

Comment 1

18 years ago
Bug reporter,

Can you clarify? Mail NEVER starts, to my knowledge and experience, unless you
start it yourself. The browser always launches separate without Mail/News ever
popping up unless I clicked on the little mail icon on the browser.

There are already a number of startup performance bugs filed, searching for them
in Bugzilla shouldn't be too difficult.
(Reporter)

Comment 2

18 years ago
I thought Mail&News were loaded (not opening the window) on startup, because 
netscape does that, and the startup does take a little time (similar to 
Netscape and Outlook Express). I had searched for bugs/suggestions about not 
loading the mail and news bug didn't find any.

Comment 3

18 years ago
i don't know if this clarifies, but under edit -> preferences, in the main
"appearance" preference panel, is the option to choose to have mozilla mail load
up on startup or not.

i suggest resolution worksforme.

(Reporter)

Comment 4

18 years ago
I found it. The mail and news are unchecked. I thought they were being loaded 
(is it possible that the data is being loaded so the window can display 
faster?) because Netscape does that, and the load times were longer than I 
would expect for just the browser.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 5

18 years ago
This bug is a total mess :)

Reporter: if you don't want mailnews, then don't install mailnews.xpi
There are a bunch of ways to do this, among them:
a) build w/ --disable-mailnews
b) grab an installer build and don't select the mailnews package

The preference checkboxes are for opening a mailnews window at startup, while 
ideally this would control whether the mailnews code is loaded at startup, it 
does not mean that yet.

Currently pieces of mailnews are indeed loaded at startup because of rdf 
references into the mailnews namespace and there is a bug to address that issue 
[it requires architecture work so it's not going to happen anytime soon].

Considering all of this, i'm going to verify worksforme based on my suggestions 
(a) and (b).  This bug could also have earned invalid or duplicate resolutions.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.