Sometimes the display of the subject in the header is interrupted abnormally

RESOLVED DUPLICATE of bug 752182

Status

RESOLVED DUPLICATE of bug 752182
6 years ago
6 years ago

People

(Reporter: mwu4, Unassigned)

Tracking

13 Branch
x86
All

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 633377 [details]
A file shows a mail with the subject displayed abnormally.

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120601045813

Steps to reproduce:

    We receive mails with unicode ( UTF8 ) encoding.


Actual results:

    Sometimes the display of the subject in the header is interrupted abnormally.


Expected results:

    The display of the subject in the header should be always normal if the encoding of the mails is the same.
(Reporter)

Comment 1

6 years ago
Created attachment 633378 [details]
A file shows a mail with the subject displayed normally.
(Reporter)

Updated

6 years ago
OS: Windows XP → All
(Reporter)

Comment 2

6 years ago
    We have used "mmencode" to decode the subject, both the eml files can be decoded normally.

1. mail_subject_display_abnormal.eml
"   Subject: =?UTF-8?B?Q29tcHV0ZXjnm5vlpKfmj63luZXvvIzkuInlpKfkuLvpoYzl?=
	=?UTF-8?B?vJXpoJjnlKLmpa3otqjli6LvvIEtMjAxMi82LzY=?=   "
" Computex盛大揭幕,三大主題引領產業趨勢!-2012/6/6 "

2. mail_subject_display_normal.eml
"   Subject: =?UTF-8?B?5Y+w5bCN5q2Q6Z2e5Ye65Y+j5LiK5o+a77yM5biC5aC05o6h?=
	=?UTF-8?B?6LO85rS96KuH5pyD5ZWG5qmf55yL5L+P77yBLTIwMTIvNi83?=   "
" 台對歐非出口上揚,市場採購洽談會商機看俏!-2012/6/7 "

Hope it helps to find what the problem is. Thank you and regards.
If each atom is decoded as base64 of utf-8 text separately, following is shown.
Utf-8 binary for "引" may be 3 bytes and split at mid by sender or server.
> abnormal.eml subject line-1 :
>   Computex盛大揭幕,三大主題
> abnormal.eml subject line-2 :
>   ��領產業趨勢!-2012/6/6
> normal.eml subject line-1 :
>   台對歐非出口上揚,市場採
> normal.eml subject line-2 :
>   購洽談會商機看俏!-2012/6/7

> Actual results:
> Sometimes the display of the subject in the header is interrupted abnormally.

What phenomenon do you call by "interrupted abnormally"?
"Computex盛大揭幕,三大主題�" is shown as Subject?
If so, it's bug 752182.
(Reporter)

Comment 4

6 years ago
WADA, thank you for your reply and it is the bug 752182. I will mark this bug as duplicate of bug 752182. Thank you.
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 752182
You need to log in before you can comment on or make changes to this bug.